iPhone4 says insert valid SIM with no PIN lock after jailbreaking

Discussion in 'iOS 5 and earlier' started by 0nyx, Oct 14, 2011.

  1. 0nyx, Oct 14, 2011
    Last edited by a moderator: Oct 16, 2011

    macrumors newbie

    Joined:
    Oct 14, 2011
    #1
    Hello,

    I got an iPhone4 that has iOS 5.0b5 installed. My carrier is ROGERS but at the moment the iPhone4 is locked to TELUS. Right now, my phone is on the activation screen that says " No SIM Card Installed-Insert a valid SIM with no PIN lock to activate iPhone" I have successfully jail broken my phone with sn0wbreeze-v2.8b8 using the following IPSW file iPhone3,1_5.0_9A334_Restore but at the end when my phone gets restarted Im still back at the activation screen. If im not mistaken i thought that after i jailbroke it i will be able to by pass the activation screen. Im so confused. If someone can give me a hand ill appreciate it a lot
     
  2. macrumors newbie

    charliehifi

    Joined:
    Jan 13, 2011
    Location:
    Stockholm, Sweden
    #2
    I'm pretty sure that installing the real software would solve your problem.
     
  3. 0nyx, Oct 16, 2011
    Last edited by a moderator: Oct 20, 2011

    thread starter macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    i have installed the real software but it wont let me activate it because its lock to TELUS and i don't have a telus sim card. I needed to be jailbroken so i can unlock the phone and use it with any carrier. At the moment, i was able to get a lil bit further with redsnow but unfortunately its gets stuck in the loading circle after reboot. i cant figure it out; its driving me nuts. i have attached a pic to make it easier to understand where it gets stuck. every time this occurs i have to restore iPhone4 to the original software via itunes. I'm also having no luck with the snowbreeze. It gives me the following error every time i try to jail break it. Anyone got an idea?

    Thanks!!!!!!!
     

    Attached Files:

Share This Page