IPhoto 6.06 “quit unexpectantly” problem

Discussion in 'Mac Apps and Mac App Store' started by DWells, Mar 31, 2007.

  1. DWells macrumors newbie

    Joined:
    Mar 31, 2007
    #1
    IPhoto 6.06 “quit unexpectantly” problem

    Running OS 10.4.9
    I dragged some jpegs into iphoto for import
    The jpegs were dated 2002 and named tom001.jpg etc.
    While importing they caused iphoto to unexpectantly quit
    When iPhoto is relaunched it begins to load photos and quits after 15 seconds
    Seems like it may still be trying to import
    I have deleted out of the library (thumbnails and originals) the photos that were imported
    I have tried rebuilding the database but iPhoto continues to quit
    I have rebuilt the thumbnails (long and short version)
    I have used disk utility to repair disk permissions
    I have tried all of the below from this apple support link

    http://docs.info.apple.com/article.html?artnum=107947


    Additionally I Have created a new user and imported the suspect photos. I photo is now stable. Also I pointed the new account to a duplicate of the damaged library to a external drive. Can not se roll names. Rebuilding small icons as a experiment.

    HELP

    Thanks in advance D Wells
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Okay, tell us how the rebuild goes. If it's successful, then try removing the iPhoto preference file (com.apple.iPhoto.plist) in your main account and then rebuilding the library again. :)
     
  3. DWells thread starter macrumors newbie

    Joined:
    Mar 31, 2007
    #3
    Does that normally work in the case of iphoto quiting before rebuilding the database? Rebuilding the icons is never a problem?

    Did a variety of things includeing running a program called mainmenu. Deep cleaned the system cache. WONDERUL. Put the com.apple.iPhoto.plist back into pref folder and boom all is working. In the event I had trashed the com.apple.iPhoto.plist would rebuilding the database hace recreated roll numbers etc?? When I did my experiment on the external drive as a differnet account name the photos came up but no roll names. 25,000 photos whoa no names!
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Not sure that I understand your questions? Are you saying it's all working now? :eek:
     

Share This Page