iphoto crashing

Discussion in 'Mac Apps and Mac App Store' started by shiunn, Mar 13, 2007.

  1. shiunn macrumors 6502

    Joined:
    Dec 18, 2006
    #1
    hello ppl,
    my iphoto keeps hanging. I import my photos and video clips into the library. and i must have done some renaming and moving around in the finder. When i go into iphoto, it will show up a msg sth like "***.mpg cannot be found", then hangs.

    i know i should have let iphoto take care of my photos, but i'm pretty meticulous. and another reason i thought i could rename the files without worrying is because i thought the "journaled" mac ox format allows exactly just that - moving files around without worries. guess i was naive.

    so, any help with my hanging iphoto please?
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Try rebuilding your library and avoid moving or renaming anything in the iPhoto folder (and the iTunes folder for that matter). :)
     
  3. shiunn thread starter macrumors 6502

    Joined:
    Dec 18, 2006
    #3
    talking about itunes, i tried moving one folder from the desktop to the "music" folder, and itunes played fine.
    that caused me to think iphoto would be the same...hehe
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    You can move stuff to the Music folder and the Pictures folder, but try avoiding to move stuff around, into or out of the iPhoto and iTunes folders. How'd the rebuild go? :)
     
  5. shiunn thread starter macrumors 6502

    Joined:
    Dec 18, 2006
    #5
    gave up on rebuild. too many "cannot find" showed up, so just deleted everything, and import manually.

    the problem with importing manually is that the same "cannot find" error message shows up!! and i have to guide iphoto to the correct folder. how weird is that!? btw, what i do in manual import is dragging the folder from finder into iphoto's sidebar.

    all these are not impressing me, especially now that my airport doesn't work after recent software update.:mad:
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Could it possibly be a system-wide problem. Do you have any theme changing apps installed? What sort of third party apps do you have running? Have you verified your disk and disk permissions in Disk Utility recently? Do you have at least 8GB of free space available on your boot drive? Are there any other symptoms apart from AirPort and iPhoto's problems?
     
  7. shiunn thread starter macrumors 6502

    Joined:
    Dec 18, 2006
    #7
    ok, let me try. I do have a theme changing apps, the OSXplanet. But wasn't running it. I don't have much third party software running at the time, probably just skype. I probably have just about 8gb of free space in my boot disk then. haven't done anything to disk utility.

    As for other symptoms, can't think of the specifics. i have a c2d, and 2gb ram from owc. it just seems that the mb is not as nippy as i had liked it to be.
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    Try uninstalling OSXPlanet and then free up your hard drive to get a bit more space. You might need more page filing room. :)
     

Share This Page