iPhoto Help

Discussion in 'Mac Apps and Mac App Store' started by idkfa, Jun 11, 2006.

  1. idkfa macrumors regular

    Joined:
    Mar 30, 2006
    Location:
    Canada
    #1
    My computer got rather bloated with alot of files after this school term, so I decided to send what I wanted to my external HD and wipe my computer. Everything went fine, of course, except that iPhoto is giving me a hard time.

    When I try to open it, it says this:
    [​IMG]

    I have reinstalled iPhoto from the disks, as well as trying to update it from apple.com.

    Help?
     
  2. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #2
    Looks like you were working on a version of iPhoto that you've replaced with an older version.

    When you wiped and dragged stuff over, did you keep any install pkgs? Go and see if you can remove the iPhoto pkg from the Library/Receipts folder (put it on the desktop rather than deleting it altogether) and then see if Software Update has an iPhoto update for you. If not, try to download it from Apple.com and install. Hopefully, that will take it to a newest version and allow your old Library to reopen.

    Otherwise, you might have to create a new iPhoto library and reimport your images.
     
  3. idkfa thread starter macrumors regular

    Joined:
    Mar 30, 2006
    Location:
    Canada
    #3
    There are three iPhoto packages there:

    iPhoto.pkg
    iPhoto504.pkg
    iPhotoContent.pkg

    Which one?

    EDIT: I think I may have it...
     
  4. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #4
    I'd try moving all three of them and then trying to update. Just don't delete them so that just in case it goes pear-shaped, you can put them back!
     
  5. idkfa thread starter macrumors regular

    Joined:
    Mar 30, 2006
    Location:
    Canada
  6. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #6
    Odd. Which version of iPhoto are you expecting to have? And is iPhoto still in the Apps folder if you go looking for it?

    Did the update come from Software Update or from the Apple site? You may want to put the pkg with the earliest date back into the Receipts folder and try that just in case it's expecting to see at least one there.
     
  7. idkfa thread starter macrumors regular

    Joined:
    Mar 30, 2006
    Location:
    Canada
    #7
    I think it is expecting 5.04??

    EDIT: It came from Software Update.
     
  8. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #8
    OK. Try leaving the 504 pkg on the desktop and putting the other two back into the receipts folder and then running the update.

    If not, I'm afraid I'm snookered. It might be worth having a search on Apple's discussion boards since there are a few iPhoto specialists over there who might be able to help out
     
  9. idkfa thread starter macrumors regular

    Joined:
    Mar 30, 2006
    Location:
    Canada
    #9
    Did not work. :( Thanks for your help!

    I think I may just create a new library and add them all back... there isn't THAT many... :eek: And I can just drag the yearly folders to iPhoto to put in the new library...
     
  10. mark! macrumors 65816

    mark!

    Joined:
    Feb 4, 2006
    Location:
    America
    #10
    Is it just me or does iPhoto need to be worked on? It is so slow and feature-less.
     
  11. puckhead193 macrumors G3

    puckhead193

    Joined:
    May 25, 2004
    Location:
    NY
    #11
    i think iphoto is pretty good. It does need some work like now.. i'm making a book from my china photo's...one of the photo's that i want to use isn't appearing in the list of photos to choose from...
    I took all my china photo's and made an album. I clicked on the album clicked on the +book to start making a book. When i got to the photo i wanted to use, it doesn't show up. Its still in the library and i can view and all but when i drag it over to the book it doesn't show up. Any ideas?

    edit - i just quite out of iphoto and then re-opened it and it was their... weird huh
     

Share This Page