iPhoto library dead...help

Discussion in 'Mac OS X Lion (10.7)' started by mst129, Aug 25, 2012.

  1. macrumors newbie

    Joined:
    Dec 29, 2009
    #1
    Today I was trying to back my iPhoto library (10.7, iPhoto 11) (less than 5 GB) to Amazon's cloud service. I needed to access the pictures from a different computer for a university project. I noticed Amazon was giving me errors...and when I tried to reopen iPhoto, all photos were gone and I saw nothing but the "To get started..." screen. What's strange is that the iPhoto library's size didn't change, and opening "All my files" in Finder still shows some of the pictures. I tried backing up from Time Machine, but iPhoto wouldn't display anything other than the "To get started..." screen. Thank heavens that I backed up everything on Time Machine...but trying to bring back an earlier version of the library didn't satisfy iPhoto. What did I do? :(
     
  2. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #2
    It sounds like the photos are still there and only the iPhoto database is corrupt. Try this process to rebuild the database.
     
  3. thread starter macrumors newbie

    Joined:
    Dec 29, 2009
    #3
    Sorry, this didn't work. Should I try reinstalling iPhoto 11?
     
  4. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #4
    I don't believe that will help. It sounds like iPhoto is opening and working, but just not seeing the library. Try opening iPhoto (I assume when it open it is blank?), then go to File menu and Switch to Library... and what do you see there? Is the iPhoto Library you want to use selected there?
     
  5. thread starter macrumors newbie

    Joined:
    Dec 29, 2009
    #5
    No such command is there. :(
     
  6. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #6
    Look at my screen grab. It is there.

    You may need to click past that welcome screen you are seeing.

    [​IMG]
     
  7. thread starter macrumors newbie

    Joined:
    Dec 29, 2009
    #7
    Even iPhoto Library Manager can't get any files out of this.

    ----------

    Not even the Time Machine backup works!
     
  8. macrumors 68020

    Joined:
    Jul 13, 2008
    #8
    Can anything else access the iPhoto library? Pixelmator? iMedia Library? Photo Browser in Mail? That could give you a clue as to whether it's iPhoto itself or the library.
     
  9. thread starter macrumors newbie

    Joined:
    Dec 29, 2009
    #9
    PROBLEM SOLVED!

    I was about to give up and bring the computer to the Genius Bar, when I found one last suggestion. I held down OPTION, clicked the iPhoto icon, and sure enough, two iPhoto library locations came up. I selected the one other than the default, and everything came back as if nothing happened!

    Thanks everyone! :)
     

Share This Page