iPhoto Library is gone since Lion

Discussion in 'Mac OS X Lion (10.7)' started by jwesty5, Jul 27, 2011.

  1. macrumors member

    Joined:
    Jul 30, 2010
    #1
    Just like the title says. I've tried restoring from time machine but those pictures inexplicably are unrestorable as well. I can't even find the files anymore. The thumbnails will flicker briefly and then turn to gray boxes. I've checked permissions and I don't think thats the problem either.

    My computer is an early 2008 iMac 2.66Ghz, 4gb 800 mhz

    iPhoto 08 version 7.1.5 I think. Can anyone please help me out.

    Thanks
     
  2. macrumors member

    Joined:
    May 21, 2010
    #2
    FIRST, take that Time Machine disk out of service. You don't want anything overwriting anything on that disk. SECOND, someone who uses Time Machine has to answer you (I use Carbon Copy Cloner) to see if you can use Finder to drill down in the Time Machine file and see if your photos are on there. THIRD, it's very possible that iPhoto 08 doesn't work on Lion, and you have to upgrade to iPhoto 11 (and therefore iLife 11 I guess) before restoring your photos. So you'll install Lion, then iLife 11, then your data only (not your old applications).

    Hopefully, someone more expert in Time Machine can answer this also. I like Carbon Copy Cloner because my backups contain whole files that I can always reach and copy to a new drive without using CCC at all. But a lot of people do use Time Machine, and hopefully they can help you with this.
     
  3. macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #3
    go into Finder and your Pictures folder

    In there you should see your iPhoto Library, do a right click on this a choose get info, how big is it? if it looks a reasonable size your pictures are in this

    right click again and select show package content, in the new window that opens you should see a folder called originals, does this have your photos?

    also from within iPhoto, right click on a photo and select show file, what does this give (photos might be stored external to iphoto library), if this is the case then you need to restore this folder from time machine

    I dont understand why time machine wont restore the files

    it backs up everything, unless you have specifically told it not to

    go into finder
    select pictures folder
    enter time machine
    go back to a date it was working
    right click on iphoto library and choose restore
     
  4. thread starter macrumors member

    Joined:
    Jul 30, 2010
    #4
    I've done all this. I've even chosen a date before I installed Lion and still all pictures prior to the install are gone. What I don't get is that when I scroll through all my photos the thumbnails appear while I'm scrolling and disappear as soon as I stop scrolling. So it seems like the pictures must be in there somewhere I just can't find them.
     
  5. macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #5
    it stores the thumbnails separate to the actual images, so you could have thumbnails but no images

    If you right click on one, do you get the option to show in finder

    also what is the size of your iphoto library through get info in finder
     
  6. thread starter macrumors member

    Joined:
    Jul 30, 2010
    #6
    When I right click the missing thumbnail it just shows my computer, network, and Mac HD with nothing to the right of it. The size of the iPhoto Library file is a lot smaller than it should be at 3.27 gb
     
  7. macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #7
    sounds like it should have photos in it, i only use iphoto to test things now, mine is only 10meg with 2 photos in it

    if you right click on it, and select show package contents, when this displays do you have anything in the 'Originals' folder
     
  8. macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #8
    another thing to try, if you havent

    hold down option+cmd when you launch iphoto

    select the option to repair library
     
  9. macrumors newbie

    Joined:
    Apr 9, 2013
    #9
    Photos will not load from library

    I read through many of these posts but I cannot find a solution to my problem.

    I have no thumbnails in my IPhoto library. When I import a photo, it appears briefly and then disappears.

    I have tried restoring thumbnails, rebuilding the database, basically all four alternatives when one starts IPhoto by holding down Option/Command. I get nothing but a spinning wheel. It goes forever!

    The library appears to be intact on my hard drive - 52 gigs

    When I switch to my Aperture library, the thumbnails return and all is well. When I try to switch back to the IPhoto library, nothing happens. I have a blank screen.

    I appreciate help or please direct me to a post that will solve this.

    Last Note: I had a hard drive crash recently and it had to be replaced. Everything was restored from a time capsule - except my photos.
     

Share This Page