iPhoto Spotlight searches

Discussion in 'Mac Apps and Mac App Store' started by UberMac, Apr 30, 2006.

  1. UberMac macrumors 6502

    Joined:
    Jan 5, 2005
    Location:
    England
    #1
    My spotlight won't search my comments in iPhoto 6. It works just fine on iPhoto 5 on my PowerBook, but my iMac returns no results for the same set of photos :s

    The comments are definitely there (I'm not that stupid) because they work just fine in the application. I've tried deleting the iphoto.ipspot file, I've tried using an application to reindex my computer and I've tried using the keywords trick (give all photos keyword, then remove it...). I can't think of anything else to try!

    Any help would be uber cool!

    Uber

    EDIT: Yes, i have searched the forum, but everybody else has had their problem solved by one of the above :(
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    I'd don't have a solution, but I do have the same problem :(

    I was thinking about have spotlight re-index my drive but if you have done that there is little point in me trying.
     
  3. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #3
    Since the keyword one seems to help with keywords, I wonder if you could append something to the comments (although obviously you couldn't remove it. Would appending a . to each one make them searchable I wonder?
     
  4. UberMac thread starter macrumors 6502

    Joined:
    Jan 5, 2005
    Location:
    England
    #4
    I haven't tried that but I have added new photos to my library since I have been aware of the issue and tagged them with comments and they also do not appear in spotlight. I'll try adding a batch comment like "photo" onto them all, which could take a while, and be back later!

    Uber

    EDIT 1: I haven't tried a rebuild of my library, though I'm kinda unsure as to exactly what that does. I don't want to completely rebuild it because I'm 99% sure that gets rid of comments and such :eek: :mad:

    EDIT 2: I tried adding a batch comment of "Photo" to all my images and had no luck :(
     
  5. HungrySeacow macrumors regular

    Joined:
    Jan 11, 2006
    Location:
    West Palm Beach
    #5
    I have tried everything... The only solution is to create a new library and start from scratch. Sorry guys, but when everything else fails, that is the only solution.
     

Share This Page