iPhoto structure/data after rebuild attempt

Discussion in 'Mac Apps and Mac App Store' started by jt6572, Sep 1, 2013.

  1. macrumors newbie

    Joined:
    Aug 5, 2011
    Location:
    Perth West Australia
    #1
    hi everyone,
    i was having the issue where the only iphoto images that were showing full sized after double clicking were the more recent of my photos.

    so i did a rebuild on the library, and since then all of the photos that werent showing the actual (sized) original image as above were all moved to the iphoto library recovered photos directory.

    as it stands, all of my events, etc. are showing fine via the iphoto interface, but whenever i try to source the original, it cant find it (as its no longer in the Originals folder). they are only now all together in the iphoto library recovered photos directory and the Show File goes to the HDD parent (top image).

    okay, so given the actual folder structure is maintained in the data directory (second image), is there a way i can avoid a blanket re-import and have all these images revert back to how they were (earlier today) before the rebuild?

    will the originals still have metadata that would magically put them all back?!

    i tried to do a time machine restore, but i am inexperienced with TM and the images affected are still just in the iphoto library recovered photos directory...

    would really appreciate any help! :confused:

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  2. macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #2
    Jeff,

    Just a stab in the dark here.

    Looking through your screenshots, I see your Finder folders being listed under "shared folders". However, I do not see that in the path bar at the bottom of Finder.

    Have you been sharing your iPhoto library and if so, have you been accessing that from another user or another system? If so, then you may have permission issues.

    /Jim
     
  3. jt6572, Sep 2, 2013
    Last edited: Sep 2, 2013

    thread starter macrumors newbie

    Joined:
    Aug 5, 2011
    Location:
    Perth West Australia
    #3
    hi jim,
    thanks very much for the reply.

    tbh i hadnt noticed they were shared until now. having said that, i am the only one who accesses them.

    in my iphoto prefs, i dont have any of the share options checked, however my parent user directory is shared. at the minute i cant remember why i would have done that?

    what do you advise? is the fact that the folder was shared a reason the rebuild didnt work?

    i have set it now to not be shared. wont mess around any more though...
     
  4. macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #4
    I do not know if it is a permissions issue or not.

    I *THINK* the way you would fix this is to:
    • Right click on Pictures, and select get info.
    • Near the bottom there is a Sharing & Permissions section... open that
    • Unlock the yellow lock in the bottom right corner
    • Highlight yourself
    • Click the gear box
    • Click to apply to enclosed items
    • Click to make yourself the owner
    To be honest, I've never had permission issues, so I am not 100% sure that is the right procedure. I'd suggest that you research it before going further.

    /Jim
     

    Attached Files:

  5. thread starter macrumors newbie

    Joined:
    Aug 5, 2011
    Location:
    Perth West Australia
    #5
    ah, its all too hard!

    i just got all the originals in the same place and created a new library.
    instead of all the events as they were i am just now creating Smart Albums...just the easy resolution.

    thanks for your help Jim.
     

Share This Page