iPhoto.....why?

Discussion in 'Mac Apps and Mac App Store' started by quigleybc, Mar 15, 2007.

  1. quigleybc macrumors 68030

    quigleybc

    Joined:
    Jun 17, 2005
    Location:
    Beautiful Vancouver British Columbia, Canada
    #1
    iPhoto is beginning to drive me nuts.

    Whenever I RIGHT click on a photo I get this message:

    [​IMG]





    Now....My iPhoto Folder is not "locked" the library is just where it's always been, on my main HD.

    I am using MY ADMIN account.....

    I updated to the newest iPhoto the other day. Still no luck..

    Truly confusing me....

    and to add insult to injury after I right click, get that annoying message, then iPhoto just SHUTS DOWN. haha, what a kick in the a$$....

    HELP! :)
     
  2. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #2
    What is that blue icon for?
     
  3. apachie2k macrumors 6502

    apachie2k

    Joined:
    May 23, 2006
    Location:
    was NYC...now MIAMI
    #3
    press :apple:-I on the folder where your pics are at, check to see if it somehoe got locked, and keep on going up directories to see if any of those got locked by accident...
     
  4. quigleybc thread starter macrumors 68030

    quigleybc

    Joined:
    Jun 17, 2005
    Location:
    Beautiful Vancouver British Columbia, Canada
    #4
    Oh

    Ya, the blue icon is custom from the David Lanham Icon collection, I set it that way for iPhoto via Candybar, that's all.

    Just pretend it's the normal ugly iPhoto icon.

    and as for the Cntl + I, ya did that, nothing is locked, that I can see anyway....I'll keep digging through directories

    anyone else?
     
  5. quigleybc thread starter macrumors 68030

    quigleybc

    Joined:
    Jun 17, 2005
    Location:
    Beautiful Vancouver British Columbia, Canada
    #5
    anyone??

    i thought this would be not too tough to assist me with...

    madjew?
     
  6. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #6
    Okay, well I haven't seen this before so we'll start at the beginning. Your folder's not locked. Have you tried rebuilding the library? :)
     
  7. quigleybc thread starter macrumors 68030

    quigleybc

    Joined:
    Jun 17, 2005
    Location:
    Beautiful Vancouver British Columbia, Canada
    #7
    uggh


    I'll try that after backing up

    I'll also go through my modifieds and originals to check if any are locked....

    thing that confuses me is that I can double click a photo, edit it all I want, and there's no problem, it's just right clicks that generate that message...
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    If the permission settings are correct on the iPhoto folder, then click Apply To Enclosed Folders and everything inside should get the same permissions. That's probably quicker than manually checking everything. :)

    If the rebuild doesn't work, then open a new account and copy across your iPhoto Library. Hold OPTION in iPhoto to select this library, open it, and see if the problem carries over. If it doesn't, then the problem is specific to your original Home folder. :)
     
  9. apb3 macrumors regular

    apb3

    Joined:
    Aug 16, 2006
    Location:
    PTSD therapy
    #9
    I had a similar issue with iPhoto a while back when they changed the way the library folders worked. Before, photos were just in their folders (i think). Now there are Original and Modified folders. This caused a few issues (mostly my fault if I remember correctly)...

    Now I just make sure I've done what I wanted to do to the correct file. Don't know if somehow this type of thing has hit you or not, but thought I'd put it out there.
     
  10. quigleybc thread starter macrumors 68030

    quigleybc

    Joined:
    Jun 17, 2005
    Location:
    Beautiful Vancouver British Columbia, Canada
    #10
     
  11. quigleybc thread starter macrumors 68030

    quigleybc

    Joined:
    Jun 17, 2005
    Location:
    Beautiful Vancouver British Columbia, Canada
    #11
    another good tip from madjew

    thanks, i'll give it a go....:)
     
  12. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
  13. mokeyjoe macrumors member

    Joined:
    Feb 14, 2006
    Location:
    Preston, UK
    #13
    This may not apply to you but I get that message sometimes too. I have my iPhoto library in my Shared folder so I can use it across multiple accounts. If iPhoto is open in the other account it can't open the library. So make sure no other apps are using the library.
     
  14. quigleybc thread starter macrumors 68030

    quigleybc

    Joined:
    Jun 17, 2005
    Location:
    Beautiful Vancouver British Columbia, Canada
    #14

    Thought that was the answer, because I recently began sharing my iPhoto library on a small home network. So I disabled the sharing options in iPhoto.

    but still, right click>error locked disc message>shut down.

    No clue...:(
     
  15. cwedl macrumors 65816

    cwedl

    Joined:
    Jun 5, 2003
    #15
    Unlocking files in your iPhoto Library

    When you don't know exactly where the locked files are, and especially if they are located in more than one folder, the easiest way to unlock them will be using the Terminal (located in the Utilities folder inside the Applications folder). Follow these steps:

    Open the Terminal.
    At the prompt, type:
    sudo chflags -R nouchg

    Note: If you highlight the text above, you will see that there's a space following nouchg. You must type this space. Also, the "r" in -R must be uppercase as shown.

    From a Finder window, drag your iPhoto Library folder onto the Terminal window. This will add its pathname to the command. When you're done, the command will look something like:

    sudo chflags -R nouchg /Users/Your_Name/Pictures/iPhoto\ Library/

    Press the Return key to execute the command. You will be prompted for your administrator password; type it, and press Return again.
     

Share This Page