iPod 2G Ressurection

Discussion in 'iPod' started by harveypooka, Apr 12, 2006.

  1. macrumors 65816

    Joined:
    Feb 24, 2004
    #1
    My lovely 20GB 2G iPod has been on the blink for a while and finally semi-died a death late last year. I got it out again, managed to charge it and it played again. It plays everything fine (apart from the odd crash/freeze where it continues to play the track with no sound) and can be charged and even recognizes the FireWire cable plugged in. My Mac does not recognize the iPod though. I've reinstalled the software on the iPod, wiped it, etc etc etc. It doesn't show up in Disk Utility either. Anyone got any bright ideas before I rip it apart, see what makes it tick and am left with a really dead iPod?
     
  2. macrumors 6502

    MmmPancakes

    Joined:
    Jan 18, 2005
    Location:
    Austin, TX
    #2

    Have you tinkered with the battery at all?
     
  3. macrumors newbie

    Joined:
    Apr 12, 2006
  4. thread starter macrumors 65816

    Joined:
    Feb 24, 2004
    #4
    Not tinkered with anything. I guess it's some problem with the iPod...but any ideas on solutions?
     
  5. macrumors 65816

    StarbucksSam

    Joined:
    Nov 21, 2004
    Location:
    Washington, D.C.
    #5
    Honestly, for the money you'd spend to fix it, you're much better off getting a new one. Or a used 2G that works right.
     
  6. macrumors 6502

    Joined:
    May 11, 2005
    #6
    IMHO you should just buy a new one because it will never work the same.
     
  7. thread starter macrumors 65816

    Joined:
    Feb 24, 2004
    #7
    I know, but I thought it would be fitting for it to be resurrected on Sunday. I really want to make it work...
     

Share This Page