iPod app not working after update to 4.0 on iPhone 3G s?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ABigGatorsFan, Jun 22, 2010.

  1. macrumors newbie

    Joined:
    Aug 4, 2009
    #1
    Since updating to OS 4.0 on my 3G s last night, my ipod app no longer works. Everytime I go to open the ipod app it stays open for a second and then shuts down. I am not able to get anything to play either through the standard ipod controls or the multitasking control panel. I'm sure there will be an update soon to correct this, i just wanted to see if anyone else was having the same problem.
     
  2. macrumors regular

    Joined:
    Jan 13, 2003
    Location:
    Detroit
  3. elb
    macrumors newbie

    Joined:
    Jun 22, 2010
    #3
    ipod app not working after upgrading to OS 4.0

    Hi folks,

    The same issue here with my IPhone 3GS. Waiting to see any patch soon.

    Eduardo Bastos
     
  4. macrumors newbie

    Joined:
    Jun 22, 2010
    #4
    Same issue as well...the iPod app opens, displays for a few seconds, then closes. I tried rebooting a few times, but I continue to have the issue. (Good thing I have my iPad to use for music at work today :))
     
  5. macrumors regular

    Joined:
    Jan 13, 2003
    Location:
    Detroit
    #5
    I'm considering doing a fresh install of 4.0. Anyone try this yet?
     
  6. macrumors newbie

    Joined:
    Jul 9, 2009
    #6
    I have the same problem. I believe it has something to do with iTunes. I have 2 3Gs' and one of them I downloaded a podcast. The one that I downloaded the podcast, causes the iPod app to crash. The one that was just updated to 4.0 works perfectly fine. Can any of you confirm that you downloaded something off the iTunes app and that caused it to break?
     
  7. macrumors newbie

    Joined:
    Jul 9, 2009
    #7
    Ironic that we finally get to background the Pandora App and now the iPod app goes.
     
  8. macrumors 6502

    Joined:
    Jun 3, 2007
    #8
    I downloaded a song from iTunes and am now having the same issue. Any known fixes out there?
     
  9. macrumors newbie

    Joined:
    Jan 17, 2008
    #9
    Experienced the same thing with my 3g. Reinstalling fixed it.
     
  10. macrumors newbie

    Joined:
    Jun 22, 2010
    #10
    I downloaded a song from iTunes this morning (via the iPhone) immediately before attempting to use the iPod app. Unfortunately, I don't know if the iPod worked before that and the download broke it, or if it happened immediately as a result of iOS 4 upgrade.

    However, I personally know of three other people who've done the iOS upgrade on their 3GS's and are NOT having the iPod issue...so, there must be some sort of combination of factors that is causing it.
     
  11. macrumors regular

    Joined:
    Jan 13, 2003
    Location:
    Detroit
    #11
    I never opened the iPod app before downloading a podcast, so I can't be sure one worked without the other -- but yes, I downloaded a podcast, and now the iPod won't stay open for more than a brief moment.
     
  12. macrumors regular

    Joined:
    Jan 13, 2003
    Location:
    Detroit
    #12
    Just read on the Apple support discussion boards that a re-syncing of the phone will do the trick to cure this. I'm away from my home computer to do that, but that's the word. So give that a try, for those experiencing the problem.
     
  13. macrumors regular

    Joined:
    Jun 18, 2008
    Location:
    Los Angeles
    #13
    I had this exact same problem. After upgrading the OS, my iPod app showed that I had no podcasts even though I had several before upgrading. I downloaded a couple through the iPhone, then the iPod would crash immediately whenever I opened it. I rebooted and resynched a couple of times without any change.

    I finally got it to work by downloading a new podcast through iTunes on my desktop and then resynching. I noticed during the synch that it was now transferring podcasts to the iPhone. After the synch, the iPod app worked fine.
     
  14. macrumors regular

    Joined:
    Jan 13, 2003
    Location:
    Detroit
    #14
    Going through the sync process again fixed the problem for me.
     
  15. macrumors newbie

    Joined:
    Jul 23, 2010
    #15
    I had the same issue

    The iPod worked after the upgrade until I downloaded a couple of songs yesterday directly. I hope re-syncing works!
     
  16. macrumors newbie

    Joined:
    Aug 1, 2010
    #16
    Sync-ing worked for me
     
  17. macrumors newbie

    Joined:
    Oct 15, 2011
    #17
    My music shows up, but doesn't always play. Or it shows a different song title / album artwork than what is playing.

    I have shut the phone down, and tried syncing it again. Neither of these things worked
     

Share This Page