1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

ipod battery problem w/ 2.1 update

Discussion in 'Macintosh Computers' started by zimv20, Nov 5, 2003.

  1. macrumors 601

    zimv20

    #1
    after an overnight charging, my ipod battery reads only 5/8 full. just before i removed it from the dock, it said it was charged.

    anyone else see this?

    i've not yet used it sufficiently to know if the battery is really only 5/8 full or if the error lies solely in the indicator.

    it's a 15 gig 3G ipod. my mac is running 10.2.6.

    also -- the update changed the indicator from a four-bar one to a single, solid one. this happened to everyone who applied the update, yes?
     
  2. macrumors newbie

    #2
    I also have this problem. The last two days my 20GB iPod says "Charged" in the morning, but as soon as I pull it off the dock it's only 5/8 full. Today I have not used it, just looked at it, and now it shows full charge. I think tonight I will charge it with the AC charger and see if that makes a difference. :confused:
     
  3. macrumors 601

    zimv20

    #3
    mine is not full, but it may have increased to 3/4. but maybe that's where it was yesterday.

    also remember now -- i tried charging it during the day yesterday. left it in the dock while i was at work. came back, unmounted it, pulled it out, and it hadn't charged at all.

    fyi - mine was also hooked up to my mac, not the AC.
     
  4. macrumors 68040

    jxyama

    #4
    the battery indicator is now a continuous bar instead of quarters, that is definitely part of the change.

    i noticed that the indicator is very slow in updating itself. i also charged mine a while back via FW port on my laptop - after overnight charging with the iPod showing "charged," i pulled the cable out. it wasn't until a few songs later that the battery indicator showed nearly full charge. it kind of trickled up to that point from 1/2 full over time...

    i haven't tested the actual battery life yet, but i suspect it's just a faulty (or slow) battery indicator.
     
  5. macrumors regular

    #5
    I have had the same problem with my iPod however, the problem does seem to correct itself after a few minutes. I even tried to charge it with the AC adapter to no avail; the same old problem. The longevity of the battery though is still about eight hours of playback though so that didn't change. It must be in the firmware update.
    - apmonia
     
  6. macrumors 601

    zimv20

    #6
    well, i'll be. i just played through most of a song (Veruca Salt, if we think it makes a difference :) and the battery indicator went to full.

    nutty.
     
  7. macrumors newbie

    #7
    I am going to run down my battery completely and then charge it overnight and watch the indicator to see how it reacts. Recharging from zero should be quite noticeable if it takes a while for the indicator to respond.
     
  8. macrumors newbie

    #8
    same problem here

    My battery only shows half full, although it's fully charged, then it shows empty after a little while.
     
  9. macrumors 6502a

    manitoubalck

    #9
    Li-ion batteries have a 3-4 year life from date of manufacture not first charge like Ni-Mh.

    If your I pod is in this range it could be time for a repacement
     
  10. macrumors 6502

    #10
    It surprises me that Im the only user that has more problems with the update apart from the battery issue discused here.
    I also have problems with contrast on the ipod screen. SOmetimes it just "flikkers"
    some songs wont play anymore. It crashes. sometimes it just stops playing. still says don't disconnect when you have allready shut down your mac. goes beserk when scrolling fast through sons.

    all thanks to 1 "update"
     
  11. t^3
    macrumors regular

    #11
    Well, the iPod has only been out for 2 years, so unless some people out there have prototype iPods, this probably isn't the problem.
     
  12. macrumors 601

    zimv20

    #12
    mine has none of those problems. have you tried resetting it?
     
  13. macrumors newbie

    #13
    i have the same problem too......

    i have the same problem too.
    ipod would show it's fully charged...
    then as soon as i pull it out. it'll be half empty.. and it seem like battey runs out very fast.....

    any solutions??
     
  14. macrumors 6502

    #14
    Well sometimes it shuts itself off or it won't play certain songs (don't know why) and then I HAVE to reset it.
     
  15. macrumors member

    #15
    I'm hold right now waiting to speak to Apple Tech support.

    I did a quick search to see if anyone else was having "my" problem.

    I guess its not just me both the "rattle" and the battery that will never charge past 5/8ths and then drain quickly.

    *ugh* I'm still on hold....
     
  16. macrumors member

    #16
    well they told me to ship it to them....

    off to apple it goes...
     
  17. macrumors newbie

    #17
    I drained the battery all the way down, recharged it overnight, and while it didn't show it was completely charged I still got 7 or 8 hours of use out of it. Maybe they'll fix this small glitch in the next update. I guess I can live it as long as I still get the same amount of use out of it.
     
  18. macrumors 6502a

    alia

    #18
    This has been happening with both my and my mother's ipods. Hers was only purchased on the Night of Panther, so it's still new. Didn't happen for me until this latest software update. Mine I always charge from the adapter, and it still happens. The first night after the update, it was 5/8ths, even though the giant charged icon appeared. The second day, it was 6/8ths, then the third day, it was 7/8ths. Now, it looks full, but who knows... I tend to agree that it's just a software issue with the battery indicator. Hopefully, it will be fixed by the next update.

    My mom's is even weirder, because it will look charged, but the battery indicator will be completely empty.

    Alia
     
  19. macrumors regular

    #19
    Mine has the same CONTRAST problem. Including the "flikkering" problem. It is really annoying.

    There was a post on Apple (I think it was Apple) somewhere, I think it was in the tech support section where they mention this. One solution was to run the iPod Updater and select RESTORE. I ran this solution, but it didn't fix it. Perhaps I need to run the 2.0 updater??

    Any ideas?

    Thanks,
    Quark
     
  20. macrumors 68000

    ZildjianKX

    #20
    The crappy thing is my restore for the 2.01 firmware freezes, so there is no way to downgrade... Apple better do something soon...
     

Share This Page