iPod Classic/3rd Party USB wall and car chargers NG?

Discussion in 'iPod' started by burnhamish, Sep 20, 2007.

  1. macrumors member

    Sep 12, 2007
    I just received my 160GB iPod Classic and discovered it will charge fine when connected to a USB port (computer or hub), but not when connected to my Boxwave Wall-plug/USB or Car/USB adapters. My iPod 5.5G 80GB powers just fine with these adapters. I do not (as of yet) have an Apple USB Power adapter.

    Is this difference somehow related to the A/V out change in the Classic? Does the Classic perhaps require more current than the adapters can provide?
  2. thread starter macrumors member

    Sep 12, 2007
    I don't know the technical intricacies of the charging circuit of the iPod Classic, but it appears to have changed from that of the iPod Video 80GB. Boxwave found this out when iPhones would not charge with their charging adapters, and made a cable adapter (which probably reverses the VCC and GND pins). Check out their site.

    Thanks, burnhamish! I was beginning to think no one could help me. I contacted Boxwave and they were unaware this issue also affected the Classic. They confirmed it there, and also confirmed the iPhone adapter also works for the iPod Classic. They offered an adapter to me for half off.

    Glad to be of service! We're all here to help!
  3. Moderator emeritus


    Jan 19, 2003
    London, England
    You know what they say about talking to yourself don't you?;)
  4. thread starter macrumors member

    Sep 12, 2007
    One effect, apparently, is consolidation of multiple successive posts... :rolleyes:

Share This Page