iPod kills my headphones?

Discussion in 'iPod' started by winterdude010, Jun 20, 2008.

  1. winterdude010 macrumors regular


    Feb 24, 2006
    New York
    So recently my iPod has been acting strange. I have gone through 3 sets of earbuds (2 Apple, 1 Sony) and 1 pair of actual headphones made by Coby. All of these have broken within about 2 hours of use with my iPod. The weird thing is that only the left ear will break (By break I mean the left ear no longer produces sound). The right will continue to function normally. And sometimes is I jiggle the wires or the connection in the headphone jack it will play but only for a max on 5 seconds or so. And if I plug the headphones into any other device the left ear will not work for that either. The iPod essentially kills the left side of my headphones and pretty much renders them useless as music in one ear is kind of annoying. So what is my iPod doing to these headphones?? (All but one of the Apple earbuds were brand new mind you).
  2. wpc33 macrumors 6502


    Jul 2, 2006
    Vancouver, BC
    Your headphones were all pieces of crap. I've killed four pairs of apple buds, and my Grado's are still good after two years, for example. Headphones are usually poorly made, with such low-gauge cords in the name of chic. The cheap soldering of already fragile cord in an apple bud, will get loose and snap.
    My advice is to research headphones and get a pair that you know first-hand sound good and are well-done.
    Good luck!

Share This Page