iPod Mini (4Gb) will not power on

Discussion in 'iPod' started by KentV, Sep 17, 2005.

  1. KentV macrumors newbie

    Joined:
    Sep 17, 2005
    Location:
    Eastern Canada
    #1
    Hey folks,

    I have a iPod mini that's only a couple of months old. It's only been used maybe 20 times so far. Today when I went to use it, it would not power on (it worked fine last night). Even when I plug it into my eMac, it won't come on.

    Any suggestions or am I just returning this puppy to Apple?

    KentV
    ...should have waited for the Nano....
     
  2. tech4all macrumors 68040

    tech4all

    Joined:
    Jun 13, 2004
    Location:
    NorCal
    #2
    Have you tried resetting it? Hold down the center button and Menu (or it could be Play/Pause, forgot) for ~5 second I think it was. This happened to me once and that did the trick.
     
  3. applemacdude macrumors 68040

    applemacdude

    Joined:
    Mar 26, 2001
    Location:
    Over The Rainbow
  4. KentV thread starter macrumors newbie

    Joined:
    Sep 17, 2005
    Location:
    Eastern Canada
    #4
    Reset doesn't work

    Hey,

    Thanks for the reminder to reset but it's still not go..."I think she's dead Jim" :)

    What do you folks think

    KentV
     
  5. applemacdude macrumors 68040

    applemacdude

    Joined:
    Mar 26, 2001
    Location:
    Over The Rainbow
  6. KentV thread starter macrumors newbie

    Joined:
    Sep 17, 2005
    Location:
    Eastern Canada
    #6
    You are my hero - it worked - THANKS SOOOO MUCH
     

Share This Page