1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

iPod Not Recognized (trust me, I searched)

Discussion in 'iPod' started by deeforce, Sep 8, 2007.

  1. macrumors newbie

    Initially I chalked it up to the iTunes 7.4.1 update. Prior to that everything was cool. After that, when I connect my iPod I get the "not recognized" song and dance. I tried resetting. Nothing. Restarting. Nothing. Cursing. Nothing. Like most other stories, charges fine and is identified in the USB section of About This Mac.

    Took it to the Apple store. It mounted just fine to their machine with the same OS (10.4.10) and version of iTunes, just dramatically different machines (he connected to a Mac Book, I'm using a Cube). The little tool at the iPod Bar suggested we restore it. Reluctantly, I agreed. Again, mounted to their machine just fine.

    Got home, connected and... nothing. Shows up on my desktop for a flash before I get the message. I've tried using firewire, but my iPod stopped responding to FireWire for some reason long ago. Totally stumped... and kinda irritated. Help!
  2. Moderator emeritus


    To isolate the issue between bad preference files and a hardware problem on your Cube, please create or log into another account and see what the plug-in behavior of the iPod on that other account is.
  3. macrumors newbie

    Fascinating! Mounted with no problem under the new account. Switched back to myself and it took it a second but it decided to not recognize it again. Now what?
  4. Moderator emeritus


    Hmmm...good question. :eek: ;) :D

    My guess is that it has to do with a corrupt preference (plist) file somewhere -- these are generally in the preferences folder of the Library (/users/you/library/preferences) ... but the question is whether it's an iTunes one, one somehow related to USB, or something else....

    Typically, the way you deal with this is to close the program in question and then delete this file. It gets recreated when you open the program again. Typically it can involve losing some preferences. Instead of deleting it, you can also drag it to the desktop (move it), so that if it doesn't solve the problem or does something catastrophic, you quit the program again and then drag it back.

    Some of the possible culprits could be:

    com.apple.ituneshelper.plist (actually this is a good one to start with... nothing bad should happen if you delete this, as it has no user-definable preferences).
  5. macrumors newbie

    Tried both of those and still nothing... I'm ever so sad. :-(
  6. macrumors newbie

    I feel ur pain man!:(
    the same thing happen with my mac min and the new video nano!!
    WTF! :mad:
  7. rdt
    macrumors newbie

    try resetting your ipod

    I was having a similar problem. One day my ipod nano was not recognized at all on my macbook pro. I found a post that suggested resetting the ipod. http://docs.info.apple.com/article.html?artnum=61705
    quick version: hold down the menu and centre buttons at the same time until the apple logo appears.

    I did this and it solved the problem. ipod is recognized now!

Share This Page