Ipod Touch 2g won't restore

Discussion in 'iPod touch' started by Gringolocomatt, May 12, 2010.

  1. macrumors newbie

    May 12, 2010
    Hey guys,
    I know there are millions of other threads out there about how to restore an iPod Touch, but I haven't had any luck WHATSOEVER. One day my iPod just completely shut off on me (battery is fine) and wouldn't start back up. When I finally did get it to turn on, it went to the connect to iTunes logo. So, figured I didn't have a choice but to restore it. I tried, but I got nothing. So I tried in DFU mode, still nothing. I've tried restarting, different computer, changing USB ports, different firmwares (3.1.2, 3.1.3, JB 3.1.2) and every time I get either error 1603 or 1604. It's really killing me. I'm going on a trip in a week, and I really hoped I would have this to help pass the time in the air. If anybody has any ideas, please let me know. I'll try anything.
    Also: the iPod hangs on the Apple logo with loading circle after every time I try to restore it. If I leave it like that long enough (about 10 mins) it finally restarts with a white screen flash and then back to the connect to iTunes logo.
    Thanks, I will really really appreciate anybody who can get this workin for me.
  2. macrumors 6502a

    Oct 20, 2008
    Last time I had multiple 16XX errors after spending 2 days pulling my hair out I ended getting past it by uninstalling every piece of Apple software from my PC, iTunes, Bonjour, iTunes Helper, iTunes Updater, Quicktime, Apple Mobile Device Support.... etc. Then went through my system and deleted any remaining files and folders that were left behind related the software I had uninstalled, the only thing I kept in my iTunes library was the mobile applications folder, my music and video files. I then rebooted and reinstalled an earlier build of iTunes 9, connected my touch and put it into DFU mode and it was recognized and restored with 3.1.2 first try and has not been a problem since. It is a pain in the bum and took a few hours to update iTunes again and reintergrate my library but is the only solution that worked for me. I have since run into a couple of other people who have had success with the same process. Hope it helps.
  3. macrumors newbie

    May 17, 2010
    My iPod Won't Restore ethier!!!!!

    PPPLLLLLLLLEEEEEEEAAAAASSSSSEEE HELP!!! I was in the process of jailbreaking my 3.1.3 ipod touch and then it showed connect itunes and it won't restore it has a unknown error 9. please help!!!:confused::confused:
  4. macrumors 6502a

    Oct 20, 2008
    Basically the same approach as I mentioned above, there is also a an error 9 recovery video HERE
  5. macrumors newbie

    May 17, 2010

    Sorry, I didn't really read it.... I'm new here and I don't know how to make I own thread. So.... when I saw this thread I thought someone could help me out that was already answering to this thread. And my iPod has been screwing up.

Share This Page