Ipod Touch 4g wont connect to internet on Airport Extreme 5g

Discussion in 'iPod touch' started by Harbinger1, Nov 16, 2011.

  1. macrumors newbie

    Joined:
    Nov 16, 2011
    #1
    Hello,

    I have an Ipod touch 4g with IOS 4.3.1 and it is connect to a Airport Extreme 5g, it was working well for the last month, but today my Ipod wont connect to internet (mail, safari and every other apps) but I am connected to the network with full reception.

    I tried rebooting both the router and Ipod several times, it did not helped.

    The Airport Extreme's FW is 7.6 (I updated it last week).

    Anyone got a suggestion?

    Thanks in advance.
     
  2. macrumors 6502a

    Joined:
    Mar 29, 2011
    Location:
    Orlando, Florida
    #2
    Update your iOS.
     
  3. thread starter macrumors newbie

    Joined:
    Nov 16, 2011
    #3
    I can't its pretty much the last IOS version that has an untethered jailbreak.

    I would like to add that there is 1 MBP and 3 Imacs on the same router and they are working well.
     
  4. macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #4
    There's your conundrum, update and lose the jailbreak or don't update and be stuck with wonky WiFi.
     
  5. thread starter macrumors newbie

    Joined:
    Nov 16, 2011
    #5
    Is it really the IOS?

    Because I had over a year and had zero problems until now, plus it is working on every other networks.
     
  6. macrumors 6502a

    Joined:
    Mar 29, 2011
    Location:
    Orlando, Florida
    #6
    I would be highly, highly surprised if it was not related to your OS.

    Plus, if you read what YOU wrote above -- you pretty much answered your own question.
     

Share This Page