iPod touch copies songs but they don't show up

Discussion in 'iPod touch' started by Sepultura, Jul 27, 2013.

  1. macrumors regular

    Joined:
    Jul 10, 2013
    #1
    This problem has been annoying me ever since I got this iPod Touch. I hate iTunes, but I have no choice to use it for copying songs to my iPod.

    There are certain songs I copy to the Touch which will successfully transfer over via USB. They can be found on the iPod in iTunes no problem. However when I look at artists/songs/albums/genre on the iPod they are nowhere to be found.

    BUT, they can be found by searching using music search or general search.

    This makes no sense? They are all tagged properly like the rest of my music. :confused:
     
  2. macrumors 68040

    Zmanbaseball2

    Joined:
    Aug 24, 2012
    Location:
    New York, USA
    #2
    Take some screen shots so I can better help you. Try to unsync and resync the music.
     
  3. thread starter macrumors regular

    Joined:
    Jul 10, 2013
    #3
    I manually sync my songs.

    [​IMG]
    [​IMG]
     
  4. macrumors 68040

    Zmanbaseball2

    Joined:
    Aug 24, 2012
    Location:
    New York, USA
    #4
    Try a hard reset. Hold power and home button until apple start up logo comes. Report back.
     
  5. thread starter macrumors regular

    Joined:
    Jul 10, 2013
    #5
    Hard reset will wipe the phone? So I need to do a backup.
     
  6. macrumors 6502

    Joined:
    Dec 10, 2008
    #6
    Try the Compilations menu.
     
  7. macrumors 68040

    Zmanbaseball2

    Joined:
    Aug 24, 2012
    Location:
    New York, USA
    #7
    iPod touch copies songs but they don't show up

    Nothing will get deleted.
    It's like rather than turning off a computer you click the restart button.
     
  8. macrumors regular

    Thraun

    Joined:
    Dec 18, 2008
    Location:
    Abbotsford, BC
    #8
    Are these songs downloaded from a source other than iTunes? I don't care about the legal aspect, but it may have missing/incorrect metadata that's causing it to be misfiled on the iPod. In iTunes, select the song/album in question and File->Get Info. You can manually edit metadata there.
     
  9. thread starter macrumors regular

    Joined:
    Jul 10, 2013
    #9
    Already check compilations.

    My music is CD rips. I am very picky about everything having the right id3 tags, metadata, and high quality album art. Foobar is my main music player and it's super organized.

    Hard reset did not fix the problem.
     
  10. macrumors 68040

    Zmanbaseball2

    Joined:
    Aug 24, 2012
    Location:
    New York, USA
    #10
    On a side note about the song info, I I use TuneUp media and it works great if you have a real copy a cd or iTunes because it may think it is a different song. I am the same way as you with my music collection.
     
  11. thread starter macrumors regular

    Joined:
    Jul 10, 2013
    #11
    I do everything manually I don't trust automatic programs.

    I was using iTunes for a while on one computer and what a disaster. I think it was iTunes 9 or 10 as it was about 2 years ago. It tagged files incorrectly all the time using 'Get Info.' Seems like they fixed it in the new version.

    Anyone else got an idea?
     
  12. macrumors regular

    Joined:
    Jul 19, 2013
    #12
    iPod Touch 5G? I never had this problem before but I'll ensure that the iDv3 data; where you put your information like Artists, Song, Album, Year are in order but I can see that you did it right, otherwise it wouldn't show up under Artist, Albums, etc. Have you tried using a third party software there's this one program I love and trust called mp3tag (it's free), give it a try and see if it fixes your problem.

    On a side-note (hope you don't mind) whenever I make a playlist and add songs to my playlist I always get double or triple copy of the song, example if I copy:

    Beyonce - Single Ladies to a playlist named "Dance"

    Instead of copying only one, my iPod would make duplicates sometimes up to 4 copies, I am making playlist via iPod not iTunes anyone has this problem?
     
  13. macrumors regular

    IronWaffle

    Joined:
    Sep 9, 2008
    Location:
    Maryland
    #13
    Of I read you right, this is a problem I've had lately. Not sure how long it's been going on, though. The solution I've found to work for me is:

    1) select all tracks affected.
    2) right click and select "create playlist from selected tracks"
    3) go to the new playlist, select all and uncheck all
    4) sync device
    5) recheck files in playlist then sync again
    6) verify in device
     
  14. thread starter macrumors regular

    Joined:
    Jul 10, 2013
    #14
    No problem ask your questions, hopefully someone here can help. I have never had that problem.

    It's an iPod 4g.

    I also notice my playlists are randomly getting deleted. They don't appear in iTunes when I make them on the iPod. Then they just disappear from the iPod.

    This worked. Well it worked as in it made a playlist and I can see the songs.

    They still do not show up in the artist or genre tab, but they do in songs and albums. :confused:
     
  15. thread starter macrumors regular

    Joined:
    Jul 10, 2013
    #15
    Still have not resolved this issue.

    Now a new issue appears...

    I added new songs by a different artist to the iPod touch.

    Two artists that were on on the iPod and visible before have now disappeared. Now I can only find them by doing a search. I cannot find them artists and also the specific genre tab says 'No Music.'

    What the heck is wrong with this iPod Touch? Never did I have this problem with my Nano, Mini, or Classic.
     
  16. macrumors 68020

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #16
    re: your original problem.....
    Is "Group By Album Artist" turned on in settings?
    Any chance that your Artist metadata is correct but your Album Artist metadata is wrong or missing?
     
  17. thread starter macrumors regular

    Joined:
    Jul 10, 2013
    #17
    Yes Group By Album Artist was turned on. I turned it off and now the songs show. Thanks.

    None of my metadata is incorrect I made sure.

    It doesn't make any sense though that the music originally showed up... then when I added different artists, old music would disappear and could only be found by searching.
     

Share This Page