Ipod Video - Missing Tracks!!!

Discussion in 'iPod' started by mixmasterhaste, Jun 9, 2006.

  1. mixmasterhaste macrumors newbie

    Joined:
    Jun 9, 2006
    #1
    Hey everyone, i just bought a new 60GB Ipod Video. I have had an older version, and it had worked fine! Anyways, the new ipod video will not show some songs in the "artists" menu even though they have been downloaded onto it. When doing a search for the song under the "songs" menu, i can easily find these missing songs (i shot the sheriff, jammin etc) . I realized i may have not have named the artist correctly which may explain why i couldnt find the song under the artist search. I turns out that everything was named properly, and the ipod would just not show those songs when looking for them in the artist menu!!!! I reformatted the ipod and started from scratch, reloading all the songs again and making sure everything was labeled properly, but it didnt help at all!!! The songs are still on the ipod, but i cant find them under the artist menu!!! The same songs worked and appeared just fine on my older ipod...WHATS GOING ON HERE?!?!?! Has this happened to anyone else??? :confused: :eek: :mad: :(
     
  2. Kardashian macrumors 68020

    Kardashian

    Joined:
    Sep 4, 2005
    Location:
    Britain.
    #2
    If you have different songs, from different albums and singles, but the same artist. This sometimes causes problems.

    For example, I have a 3 Alicia Keys' albums. However, I have a live-recording of 'Karma' that is not from a CD, it is a Video-Rip.

    Therefore, it doesn't have an album name, so when I browse via Artists > Album > Only album names are shown, so I cannot select this particular song.

    However, if I go into Songs > and down to 'K', 'Karma (Live)' will be there.

    Hope that helps. :)
     
  3. chairguru22 macrumors 6502a

    Joined:
    May 31, 2006
    Location:
    PA
    #3
    i have this same problem as the OP. dont have an answer though... anyone?

    what j.t says above seems right but the same issue with other artists doesnt have this problem. some songs have albums and some dont and they work while others do not. My billy joel and usher songs dont all come up. i have 20 joel songs and only 1 shows up...

    im converting all the ID3 tags to v2.2 ATM, anyone know what this does and if it will work?
     
  4. charlie69 macrumors newbie

    Joined:
    Sep 14, 2006
    #4
    I had the same problem with my 30GB video ipod and I have found the answer!!! when you select an artist it comes up with another step involving you to select the album and at the top you have 'All' If you select 'All' all the songs from that artist should be there even if they are not on an album.

    However if you have only one album from the artist but have some tracks that are not on a named album from the same artist then ipod video skips the step of choosing an album and goes straight to the one and only album there and only shows the songs that are on that album. so the songs that are not on the album are not shown.

    The only way I can see to get round the Problem is to go on itunes and either get rid of all the album names so that every time you go to the artist it will show all the songs. Or to write atleast 2 album names for each artist so that when you select the artist it will give you a choice of albums but at the top it should have 'All' so all the songs should be there.

    Hope this helps
     
  5. SPinc33 macrumors member

    Joined:
    Sep 19, 2005
    #5
    same problem

    i have the 5g 60Gb and have the same problem from time to time. I've checked all the suggestions that have been made and it is clearly a glitch. Some files simply don't show up at all under their respective artists.

    I have only noticed the problem a few times, but it is quite annoying. The song is already on the iPod, just not in its proper artist folder!
     

Share This Page