iPod won't play songs that I bought through the music store.

Discussion in 'iPod' started by usagent, Jun 30, 2005.

  1. usagent macrumors newbie

    Joined:
    May 25, 2005
    #1
    Hi all,

    I have a 3G iPod with Dock connector. I upgraded to iTunes 4.9 and updated the software on my iPod to handle podcasts. Since then, whenever I ant to listen to songs on my iPod, it skips to the next song in the album, not playing the song, and continues to skip until it gets back to the main menu. This only happens with songs that I legally purchased from the iTMS. It plays fine if I hook it up to my powerbook and listen through iTunes, but not when I try to listen to it by itslef. Any thoughts? Has this been happening to anyone else? Oh, and I only have 2 computers that are authorized. Does that make a difference at all?

    Thanks!
     
  2. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #2
    It happened to me last month for no apparent reason at all with a 4G iPod

    I was able to fix it temporarily by resetting it (can't recall which combination of buttons it is on the 3G iPod). But it occurred again, along with a strange freezing bug.

    I ended up restoring the firmware to factory defaults and then it worked perfectly again. Still have no explanation as to why it stopped working though.
     
  3. Sharewaredemon macrumors 68000

    Sharewaredemon

    Joined:
    May 31, 2004
    Location:
    Cape Breton Island
    #4
    I'm getting this problem too, it's a good thing I searched.
    I was thinking that a firmware restore would do it.

    Reset didn't fix it though.

    What is weird is that it will happen intermittently. If I connect my iPod to the computer usually it will work fine.

    I have another idea of what it could be.

    If you connect your iPod to another computer (one that isn't authorised to play the purchased songs) and you tell iTunes NOT to sync to this computer, could it automatically make the songs on your iPod unplayable?
     
  4. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #5
    That's not what it was in my case. It worked one day in the office and it didn't the next... no plugging in anywhere in between. It hasn't done it since then.
     
  5. Sharewaredemon macrumors 68000

    Sharewaredemon

    Joined:
    May 31, 2004
    Location:
    Cape Breton Island
    #6

    I tried replicating the problem, it didn't happen.

    I'm still sending a bug report to Apple.

    Have you guys noticed that you can't send feedback about iTunes the app?
    When you are in the feedback section for iTunes on Apples site, the reasons for feedback are all pertaining to the music store.

    That really bugs me.
    AND, they don't have the latest version of iTunes when they ask what version of iTunes you are using.

    grrrrrr
     
  6. jamaiken macrumors newbie

    Joined:
    Jul 27, 2005
    #7
    that happened on mine, but I used the iTunes to authorize the song, and it loaded fine.
     
  7. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #8
    Hmmm... mine did it again the day after I posted the above. I restored it and tried the authorise/deauthorise which worked fine.

    Unfortunately, today's it's doing it again (a week later) with the added wrinkle of freezing occasionally on CD songs and having not transferred all my playlists over. I even seem to have one 'blank' playlist with no name and no songs in it - just a space in the listing and an arrow to go into it.

    Since I've only got a month of warranty left on it (and with it happened twice in a week), I'm taking it into the Genius Bar tomorrow in case it's a symptom of something more serious.
     
  8. Applespider macrumors G4

    Applespider

    Joined:
    Jan 20, 2004
    Location:
    looking through rose-tinted spectacles...
    #9
    I took it back into the Regent St Apple Store today and the Genius figured that the software had somehow been corrupted tho he couldn't tell how. He did suggest that it might be something on the PB that was causing it although since it works happily for periods while still being updated, he wasn't entirely sure what. But since it's now been restored a few times, he figured that replacing might be the best option.

    So I now have a refurbed 40GB iPod which is much shinier and less scratched. It's merrily updating 3000 songs now... yawn. Since mine was 11 1/2 months old, this is likely to be slightly newer with a fresher battery so will keep fingers crossed!
     
  9. rockthecasbah macrumors 68020

    rockthecasbah

    Joined:
    Apr 12, 2005
    Location:
    Moorestown, NJ
    #10
    well if you want a dirty way to fix it, use JHymn to strip off the digital rights management crap on the songs :D :D
     
  10. superapple93 macrumors newbie

    Joined:
    Jun 26, 2008
    #11
    same problem, no solution, FUMING MAD!

    I could just kill iTunes right now! I bought a whole bunch of Sugarcult songs off an iTunes gift card that my friend gave me and some of them will play but then a few of the ones i really wanted won't. They play fine through iTunes but not on my iPod (which is kinda where I want them cuz I'm going on vacation)
    When I play them on my iPod, it shows the song for a second but then skips song after song until it finds the next one that will play.
    I have reset all settings on my iPod and I have all the updates I can get through iTunes and the problem isn't fixed.
    It feels like a total waste of money!
    I would tell apple about this but i dont know how to email them....
    If anyone has anything else i can try i would really really appreciate your help
    (btw, i have a video iPod)
     

Share This Page