iPT 2G, no sound after water damage? Faulty jack?

Discussion in 'iPod touch' started by craig1410, Nov 21, 2010.

  1. craig1410, Nov 21, 2010
    Last edited: Nov 21, 2010

    macrumors 6502a

    Joined:
    Mar 22, 2007
    Location:
    Scotland
    #1
    Hi,

    I have an iPod Touch 2G which had water damage a few months ago and I was unable to fix it at the time for whatever reason. I'm an electronics engineer by the way so know my way around electronics. I decided tonight to break it up for spares but tried powering it up while out of the enclosure and lo and behold it started working!

    Unfortunately I broke the digitiser taking it apart (rookie mistake I know...) so I've ordered a new digitiser and frame which should be here in a couple of weeks.

    However, although it all appeared to be in good shape when I ordered the new digitiser, I have now discovered that the sound isn't working. Whether I use the onboard speakers or the headphones I get nothing. Also, in the iPod app, when I click the play icon it changes briefly to become a pause icon and then goes back to play again. No sound is emitted. I don't get any key clicks or any other system sounds either.

    My thoughts are that it might be the headphone jack because I know it has some extra switches in there to sense the click switch in the headphone lead for skipping tracks and pausing/resuming music etc. Has anyone come across this sort of fault?

    I've tried doing a factory reset and upgrade from 3.1.3 to 4.1.0 software but no difference.

    Any advice would be most welcome - I'm so close to bringing this little machine back to life again it is frustrating to hit this problem. I don't really want to spend any more money on it though unless I have good reason to expect a new headphone jack to fix my issue.

    Many thanks,
    Craig.
    :)

    Update: Just tried it in an iPod speaker dock and I can't get any sound there either. Again it just shuts off playing before any sound has started to play. The icon goes to pause and then back to play again if you know what I mean. Grr...
     
  2. macrumors newbie

    Joined:
    May 8, 2012
    #2
    speaker prob

    Hi just seen your post and wondered did you ever get the problem sorted, I’ve got exact problem
    Thanks Ian
     

Share This Page