Irssi opening automatically when Terminal Starts

Discussion in 'Mac Apps and Mac App Store' started by Benjamindaines, Mar 11, 2007.

  1. Benjamindaines macrumors 68030

    Benjamindaines

    Joined:
    Mar 24, 2005
    Location:
    A religiously oppressed state
    #1
    I don't know why but Irssi keeps starting when ever I star the Terminal.app. Any way to just make it come up to the shell instead of irssi?
     
  2. iMeowbot macrumors G3

    iMeowbot

    Joined:
    Aug 30, 2003
    #2
    First, in Terminal preferences, make sure that the default login shell option is checked, and that "open a saved .term file" is empty/unchecked.

    If that looks clean, look for files named .profile and .bash_profile (there could be one or both) in your home directory. Make sure that there isn't an irssi command in either one. (You probably want to remove the offending command, if any, with a text editor, but keep the files around)

    Do those places turn up anything?
     
  3. ekelblom macrumors newbie

    Joined:
    Oct 18, 2008
    #3
    I've got the same problem. I have the file profile in my home directonary.

    The only information in there was "test -r /swe/bin/init.sh && . /sw/bin/init.sh, which i tried ereasing with no result.

    The checkbox for default login shell in also not filled in.

    The problem come after installing irssi with fink.

    Irssi app is locaded in /sw/bin/irssi instead of /Application/Utilites/Terminal, like all other apps.

    Edit: One solution is connecting to my own computer thru ssh but that feels... a little bit geeky ;-)
     
  4. jackerin macrumors 6502a

    Joined:
    Jun 29, 2008
    Location:
    Finland
    #4
    Have you tried deleting the com.apple.Terminal.plist file?
     

Share This Page