Is OS X Lion compatible with parallels 8

Discussion in 'Mac Apps and Mac App Store' started by gwill, Feb 1, 2013.

  1. macrumors newbie

    Jan 24, 2013
    Or do I need to upgrade to Mountain Lion...Thank you.
  2. macrumors 6502

    Aug 19, 2011
    California, USA
    Software Requirements

    Mac OS X Mountain Lion 10.8
    Mac OS X Lion 10.7.4 or later
    Mac OS X Snow Leopard 10.6.8 or later
    Note: Mac OS X Leopard v10.5.x is not supported in this version of Parallels Desktop.

Share This Page