Issues with 1 week old Air 128g 11 inch i5

Discussion in 'MacBook Air' started by macbrooke, Sep 26, 2013.

  1. macbrooke, Sep 26, 2013
    Last edited: Sep 26, 2013

    macrumors regular

    macbrooke

    Joined:
    Jun 21, 2006
    Location:
    Toronto, Ontario!
    #1
    Hey guys!!

    I just bought a new air about a week ago for work purposes and I have noticed a few things, I love the form factor and the fast boot .. however sometimes when I am working my screen goes black and I have to do a restart to get it back?

    Also tonight I went to access my iPhoto and all my albums were gone? and all the settings, I had customized on the computer were reset to factory? my email accounts were gone as well! it was prompting me to add new e-mail accounts?

    Is it possible I have a defective unit? I have been having issues with the computer freezing as well and lagging when scrolling and I would restart it and it would be ok.. but I also figured this is not normal?

    I have a 2007 macbook that runs better than my new air? is this defective? or is the SSD drive just glitchy?

    Advice?
    Thanks :)
     
  2. macrumors demi-god

    firedept

    Joined:
    Jul 8, 2011
    Location:
    Somewhere!
    #2
    Make a Genius Bar appointment. Take it in and have it looked at. This is certainly not normal behavior. They should just exchange it for a new one since you say it is only about a week old.
     
  3. macrumors 6502a

    Joined:
    Feb 3, 2011
    #3
    There were some previous posts on the blank screen issue. May be a continuation of the same blinking screen issue with Intel's HD-4000 gpu in the 2012 Mini?
     
  4. thread starter macrumors regular

    macbrooke

    Joined:
    Jun 21, 2006
    Location:
    Toronto, Ontario!
    #4
    Also worth mentioning is that it has issues with the wifi as well, it always loses connection even when I am beside my router!
     
  5. macrumors 65816

    Joined:
    May 7, 2009
    Location:
    Hamilton Island, Whitsundays, QLD Australia
    #5
    take it back for a replacement for sure :D
     
  6. macrumors 68000

    Joined:
    Feb 21, 2012
    Location:
    New Jersey Pine Barrens
    #6
    Something is definitely wrong. Have never seen any of these problems on my 2013 11" MBA after two months heavy use.
     

Share This Page