iSync + P900 / iPod contacts problem

Discussion in 'Mac Apps and Mac App Store' started by dave76, Jun 24, 2004.

  1. dave76 macrumors newbie

    Joined:
    Jun 24, 2004
    #1
    Help!! Am getting incredibly infuriated with iSync...

    I am trying to sync up my Powerbook with a new P900 and my 3G iPod. Everything connects perfectly (via Bluetooth to the P900), and my calendars sync up every time - but I can't get my Address Book contacts to sync at all, so I'm left with a blank contacts list on the phone and iPod...not helpful.

    The problem seems to be that iSync is 'filtering' the contacts that it copies to the P900 and iPod - filters them so well, that nothing is copied over.

    I have tried removing devices from iSync and re-adding them, tried resetting devices from iSync, tried deleting and then re-pairing the P900 etc etc.

    And now I'm stuck.

    I've copied in below the relevent piece of the iSync log if that might help anyone.

    Any suggestions - I'm getting desperate!

    Many thanks

    Dave

    System:
    15" Powerbook, 1.25Ghz, OS 10.3.4
    Address Book v3.1.2 (v321)
    iSync v1.4 (v132)
    P900 with latest firmware
    40GB 3G iPod with latest software

    12:30:18 Synchronizing contacts
    12:30:19 Getting all contacts from David Nicholson’s iPod
    12:30:19 Getting all contacts from Daves P900
    12:30:19 Getting all contacts from Backup Conduit
    12:30:22 contacts: 248 added
    12:30:22 Getting all contacts from Address Book
    12:30:27 contacts: 160 added
    12:30:27 Filtering contacts on David Nicholson’s iPod
    12:30:27 Filtering contacts on Daves P900
    12:30:29 Completed synchronizing contacts
     
  2. Rennie macrumors newbie

    Joined:
    Jun 27, 2004
    Location:
    Bath UK
    #2
    iSync P900

    I have just upgraded from a P800 to a 900, and neither would sync....Bluetooth shows connected, iSync finds them and then when I try to sync computer sends a "you need to restart your computer" I do then start all over again same things happens.
    I have deleted and reloaded both iSync and iCal and nothing changes

    so you have got further than I do!!!
     
  3. josepho macrumors regular

    Joined:
    Mar 12, 2004
    Location:
    Surrey, England
    #3
    Wow... Not to gloat, but my P900 works flawlessly with iSync. Although I haven't combined it with an iPod (getting one this week), I have experienced no problems. Contact sync well to and from the P900.

    Have you updated your P900's software at all? Obviously you need access to a Wintel box though... *sigh*
     
  4. iGooner macrumors newbie

    Joined:
    Jun 28, 2004
    #4
    I am having problems syncing To Do lists from iCal to my iPod. Certain To Dos don't appear, and others (that I have deleted in iCal) do appear on my iPod. I have tried Reset Devices in iSync, but to no avail.

    Anyone else having similar problems?
     
  5. petercrocker macrumors newbie

    Joined:
    Jul 25, 2004
    #5
    Calendar Sync - Got it to work finally

    So i had syncing problems with my Ericsson p900 as well. I'm syncing from Entourage using GoBetween (but it's not the problem). I can get contacts to sync, but not the Calendar and Tasks. Here's the error:

    |Pete P900| There was a problem syncing Pete P900. Try syncing again.
    Conduit Pete P900 generated exception NSSyncConduitException: There was a problem syncing Pete P900. Try syncing again..
    can't connect to the device to synchronize Pete P900.

    The last time I tried to troubleshoot this a few days ago, I re-paired the bluetooth devices. That did no good. The bluetooth connection is definitely working because I can do a file exchange and more importantly iSync syncs my contacts just fine, but not my calendar and tasks.

    First, I tried disabling the keypad lock. No luck. I then re-enabled it.

    Second, I tried turning off Salling Clicker's listener from the p900 side. I then turned on the listener again.

    So then I did the steps DMA recommended earlier:
    1.) Install P900 Manager.
    2.) Setup BlueShare in P900 Manager. Activate sharing just once Not sure why this works, but it does.
    3.) Do everything it says on this page (if you haven't already done so in other attempts to get this to work.)
    http://chrismiles.info/mac/tips/addressbook_p900.html

    Then I tried to sync again. Still no go.

    So the last few days I found some .plist file on the net that goes in to Macintosh HD > Library > Application Support > SyncService > 501. But I just over-wrote it with the file I got from here:
    http://homepage.mac.com/jasonlcarlton/share/FileSharing14.html
    I downloaded just the mandatory file and the instructions and did those. Then I synced again. It STILL didn't work.

    So i downloaded the two optional files from Brandon's instructions. I put them in the 501 folder as well and re-synced. Still not working!

    I then followed these instructions:
    http://homepage.mac.com/sspence/

    It was mostly the same stuff, however in editing this file:
    /System/Library/SyncServices/SymbianConduit.bundle/Contents/Resources/SupportedDevicesInfo
    I had to change the value to BVP900. I made sure to restart iSync, then tried again, and failed again!

    I then continued with sspence's instructions. I started the Address Book app on my mac, and clicked the Bluetooth icon in the top-left. It prompted me for a BlueTooth password, like when you setup pairing. I re-started iSync and tried syncing once again. It didn't work.

    Then from iSync, i "Reset All Devices", which forces a sync after deleting everything on the p900. The sync failed at the point it tried to sync the calendar, and failed with a blank error message.

    I then synced again, and got a lot more error messages!
    |P900| Could not connect to P900. Please check the pairing with this computer.
    Can't synchronize contacts to P900: device is not available
    Can't synchronize calendars and To Do items to P900: device is not available
    An internal error occurred. Please try syncing again.
    Assertion Failed!
    Expression: fdoRet != fdo_e_database
    File: Source/SyncEngine/FDODriver.cpp
    Line: 411
    INTERNAL ERROR: unhandled error (Assertion failure: File Source/SyncEngine/FDODriver.cpp, Line 411: fdoRet != fdo_e_database).

    I synced again, and i couldn't connect to the device at all any more for the contacts (much less the calendar). So I rebooted both devices. And synced again. It still wouldn't connect.

    I had to remove and re-plugin my bluetooth adapter in to my mac, then it synced my contacts. Then, a new error message!

    INTERNAL ERROR: unhandled AOS error (Could not find isam keyno request).
    iSync's internal database has become corrupted. It is impossible to continue syncing. The database has been reset, but you must now re-synchronize all of your devices. Please try syncing again.

    So I re-synced. And unbelieveably, it worked. And after all this, i don't know what the fix was. The only thing I can gather from this last few steps is that when I did the "Reset All Devices" it cleared the db on the p900. Then my isync db got corrupted, and it emptied it. After both were cleared, the sync worked!

    So my advice, follow the instructions from Brandon, and "Reset All Devices" and then see if it works.

    Hope this helps someone else. I've spent hours and hours on this. I hope Apple makes this easier in the future!

    Below is the list of things I didn't do, but were on my list to try if I couldn't get it working.

    -------------------

    de-install salling clicker
    Set the P900's Cable settings from "PC connect" to "Modem".
    Re-install isync
     
  6. dave76 thread starter macrumors newbie

    Joined:
    Jun 24, 2004
    #6
    Got it working!

    Phew - well this is a nice little mess that Apple and SE have managed to get us all in. Everyone who has some problem syncing their P800/900 and their Apple seems to have slightly different problems. The filtering problem that was my specific issue seems to have been fixed by uninstalling iSync using the software at this link (Just trashing the App doesn't work):

    http://docs.info.apple.com/article.html?artnum=120160

    Then reinstall iSync 1.4 (Download it from Apple again if you need to), cross your fingers, and hit Sync.

    Works for me - good luck!
     
  7. sykes macrumors newbie

    Joined:
    Jul 28, 2004
    #7
    P900 iSync - possible fix.

    I have just bought a P900 and gone through the iSync and bluetooth set up. The first sync was fine every contact and ical event transferred. The second time I tried to sync the mac gave me warnings like unable to connect with P900 etc etc.

    First I tried re installing iSync iCal etc- no change. so then I trashed the two iSync preferences listed below. They can be found in the Users/Library/Preferences -

    com.apple.isync.plist
    com.apple.isync.registry.plist

    The next sync was perfect and so far so good since. Hope this helps some of you.

    Sykes
     

Share This Page