ITMS will not connect! w/ WinXP

Discussion in 'Mac Apps and Mac App Store' started by red93xj, Sep 17, 2004.

  1. red93xj macrumors newbie

    Joined:
    Sep 17, 2004
    #1
    Everytime I try to connect it gives me this:

    iTunes could not connect to the Music Store
    Make sure your network connection is active and try again.

    I know my connection is working and I've tried disabling windows firewall but still nothing! I use norton antivirus (if it has a firewall, I can't find it or how to turn it off) I hope someone can help, its really tickin me off :mad:
    -Thanks
     
  2. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
  3. red93xj thread starter macrumors newbie

    Joined:
    Sep 17, 2004
    #3
    no, I'm using a cable modem, dlink 802.11g router, and linksys wireless card.
     
  4. djbahdow01 macrumors 6502a

    Joined:
    Jan 19, 2004
    Location:
    Northeast, CT
    #4
    Check the dlink to make sure that there isn't a firewall, or port blocked that might be needed.
     
  5. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #5
    If you've installed SP2 you'll need to make sure iTunes is in the exceptions list for Windows Firewall.
     
  6. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
  7. red93xj thread starter macrumors newbie

    Joined:
    Sep 17, 2004
    #7
    Any info on how to do that and/or what port I would need to open?
     
  8. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #8
    HTTP is 80.
    HTTPS is 443.

    I can't imagine that SP2 would block those outgoing. If so, that would just be retarded.
     
  9. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #9
    SP2 does block iTunes port- I don't know which one it is, but I did read that somewhere.
     
  10. Phat_Pat macrumors 68000

    Phat_Pat

    Joined:
    May 8, 2004
    Location:
    I Live Where I Live
    #10
    sp2 tryed to block AIM, Yahoo Messenger, even Firefox and Netscape on my PC.....

    peice of junk sp2.....
     
  11. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #11
    There is actually no reason to keep these open unless you have a http or https server running. Just because you connect to a server on port 80, doesn't mean you are using port 80 on your side. If firefox wants to connect to a web server (default port 80) it will look for the next unused, non-well known port on you computer and connect that port to port 80 on the server.
     
  12. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #12
    Okay, as of SP2 Windows will block most apps unless you add them to the exceptions list in the Windows Firewall control panel. This is a good thing, actually. By default it'll pop up and tell you that it's blocking a program (if that program hasn't already been run) and ask you what to do.

    If you've blocked a program accidentally, just go to the firewall control panel and correct it.

    Note that this is totally different from the port-by-port blocking. You can still fully open/close specific ports, but the Windows Firewall is behaving more like a real firewall now and providing more fine-grained control as well.

    I am certainly no fan of Microsoft, but I think they've pretty much done the right thing here. Too bad it's taken them so many years just to get to this point! :D
     
  13. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #13
    That is correct. But this is an outbound connection, so having a firewall block it outbound is preposterous. Sorry if that was not what I obviously meant.
     
  14. grapes911 Moderator emeritus

    grapes911

    Joined:
    Jul 28, 2003
    Location:
    Citizens Bank Park
    #14
    Ahh, I misunderstood what you were trying to convey. My apologies.
     
  15. jane doe macrumors 6502

    Joined:
    Feb 18, 2004
    #15
    Also internet accelerators will block the iTunes Music Store, Make sure you are not running any type of speed enhancers.
     
  16. red93xj thread starter macrumors newbie

    Joined:
    Sep 17, 2004
    #16
    ITMS wouldn't connect even before SP2. So, I know thats not it, but any help is good help. Any other ideas?
    -Thanks
     
  17. FuzzyBallz macrumors 6502a

    FuzzyBallz

    Joined:
    May 2, 2003
    Location:
    Home of Al-Qaida
    #17
    Check your router, it could be blocking the port iTunes needs. May also want to go to Local Area Connection > Properties > Advance > Settings > Exceptions and make sure iTunes appears in the list.

    Got no prob getting track list and buying music from iTMS w/ WinXP Pro SP2 here.
     
  18. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #18
    Not really. Ever hear of spyware? Ever hear of all the crap Real used to put on your computer, unbeknownst to you?

    It makes perfect sense for a firewall to check whether an outgoing connection should be allowed or not.
     

Share This Page