It's hard to start my 2007 Mac Mini

Discussion in 'Mac mini' started by ha0rex, Jan 17, 2013.

  1. ha0rex
    Expand Collapse
    macrumors newbie

    Joined:
    Jan 17, 2013
    #1
    Hello Everybody,
    I've a problem with my 2007 Mac Mini.

    If I try to start it, the led turns on, I hear the noise of the HDD and the Superdrive, but no video, and no chime. I should think, it's a motherboard issue, but I'm persistent, so I'm trying to force-shutdown, then power on again. After about 15-20 times I'm doing this, randomly once I hear the chime, and voila, there is video on my monitor.

    Usually it boots normally, sometimes it panics, like:
    TLB invalidation IPI timeout: " "CPU(s) failed to respond to interrupts, unresponsive CPU bitmap: 0x2, NMIPI acks: orig: 0x0...
    ...
    Status bits:
    Processor context corrupt
    Error enabled
    Uncorrected error

    OR:
    Something like:
    Kernel Extensions in backtrace:
    com.apple.driver.AppleIntelCPUPoerManagement(195.0)...

    OR something like this.

    But if I restart it again, it works like a charm. I can now shut down, and start it again without no issue, and it works fine, I tried to test my RAM, HDD, and stress-test the cpu with "yes >/dev/null" in two terminal tabs, because it's T7200 has 2 cores. Works fine!

    BUT:
    If I left it turned off for a while, about 30 minutes, or more, I can't turn it on again. I have to turn on-off-on-off-on... again, while once it starts, and works perfect again.

    I already tried to reset SMC, PRAM, tried with other RAM modules, other HDD, without SuperDrive, without AirPort, without Bluetooth. The only thing I can't change in it is the CPU, I don't have an other T7200 (or T7400, T7600).

    I'm using it as a home fileserver, with 1TB HDD, works very well near my Air, with 128GB SSD. So it has uptime's like hundreds of days, I can do this 10 minutes procedure 2 times a year, but I know it's not normal, so I'm looking for a solution.

    Anybody has an idea?

    Thank you!
     
  2. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Have you ever thought about reinstalling, or if you have a bootable backup, boot up from that one.

    If this does not help it might be HW, like it works when it is warm/hot but not when it is cold, it could be because of cracks in the solder for instance.
     
  3. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #3
    Yes, tried to reinstall it, but it doesn't work.

    I already thinking about the soldering thing, so I tried to power it on, and wait while its been hot enough, turn it off, and back on, but doesn't work.

    The only workaround is to turn on-off-on-off-on-off continuously. :(
     
  4. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    What about a bootable backup, does it startup from an external without problems?
    If you don't have a bootable HD but do have a USB stick (min. 8 GB) you could install OS X on there and see if you boot from it if it's still there.

    If it is then I am afraid it is Hardware.
     
  5. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #5
    I dont't think it would work from an external hdd or pen drive, because there is no chime on startup. :( What You think?
     
  6. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #6
    Can't hurt can it, if you have some spare time I would just give it a try, you never know.
     
  7. Fishrrman
    Expand Collapse
    macrumors 603

    Joined:
    Feb 20, 2009
    #7
    Do the Mini's have a motherboard "PRAM" battery?

    Some years back, there were issues with Macs not starting because the motheboard PRAM battery was low or completely discharged.
     
  8. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #8
    Crap, why didn't I think of this, someone asked me last time, it can make a difference.
     
  9. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #9
    I already tried with another one, from my old laptop, but tomorrow I'm going to buy a new one, and give a try. Thank you! :)
     
  10. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #10
    I just found the same battery in my apple tv's remote, and gave it a try, but it seems with no success. :(

    It seem, that it depends on the time, I leave it turned off. If leave it for 10 minutes, I have to do the on-off procedure 3 times, if I leave it for an hour, I have to do it 15 times, to boot up normally.

    I have no idea. :(
     
  11. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #11
    In his first Post he says in BOLD

     
  12. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
  13. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #13
    I haven't asked this before but can you post a panic report, it says quite a bit, might find the problem in it.
     
  14. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #14
    I'm trying to find it, but I can't. Where should it be? The /Library/Logs/DiagnosticReports folder is empty.
     
  15. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #15
    In the Main Library in my case /Library/Logs/PanicReporter

    You could also try to see what your System report says.
    In /private/var/log

    Edit: Yours will probably not contain the last one since it happens at startup when the reporter is not active yet, but some things might show in the System Report.
     

    Attached Files:

  16. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #16
    I think, you're using 10.5, in Lion panic logs should be in /Library/Logs/DiagnosticReports folder, but it's empty in my case.

    I'm looking at system.log files in /private/var/log, but nothing about that panics, I saw sometimes.

     
  17. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #17
    It won't say it panics but you can see where it hangs and restarts.

    And yes, you are right, I am on 10.5.
     
  18. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #18
    But here is a system log file's content, do You see anything?
    http://pastebin.com/24wrmw4L
     
  19. justperry, Jan 19, 2013
    Last edited: Jan 19, 2013

    justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #19
    Nothing to see, but last entry is January 13, it's not been on since that date?

    Also, mine is much more verbose, I can see everything from startup to shutdown, yours is garbage, you're sure it's the right one.;)
     
  20. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #20
    There are lot more, but in separated files. :)

    I tried to find a date, when I had problems with it. I'm not sure, because its on again now for days. Kernel panic occurs only sometimes, after a long on-off-on-off procedure. Nothing bad if I leave it ON, or if I turn it off just for a little while.

    So yes, I think, we can't see anything about the problem in the log, because it's before it starts. If it starts booting, everything is fine, so nothing to write in logs.

    here is my actual sysem log:
    http://pastebin.com/DdE3fbqT

     
  21. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #21
    Nothing to see either.

    Most times the log folder in /private/var/logs also contains compressed old system log files like these,these are in my Logs folder)
    /private/var/log/system.log.0.bz2
    /private/var/log/system.log.1.bz2
    /private/var/log/system.log.2.bz2
    /private/var/log/system.log.3.bz2
    /private/var/log/system.log.4.bz2
    /private/var/log/system.log.5.bz2
    /private/var/log/system.log.6.bz2
    /private/var/log/system.log.7.bz2

    If there are such files in yours there is a history in it, if you want to see it, drag those to the desktop, untar ( compressed file ) them and you can open them with TextEdit.
     
  22. OLDCODGER
    Expand Collapse
    macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
    #22
    To be honest, I would suspect a faulty PSU. A dodgy relay or capacitor can give intermittent powerups.
     
  23. Fishrrman
    Expand Collapse
    macrumors 603

    Joined:
    Feb 20, 2009
    #23
    I'd like to offer something else to try. It may help, or have absolutely nothing to do with your problem.

    Question:
    Do you keep the Mini plugged directly into the wall, or into a power strip?

    Suggestion:
    If you keep it plugged into the wall, when you shut down, try pulling the plug out of the wall. Plug it back in the next time you turn it on. Any difference?

    If you keep it plugged into a power strip, turn the power strip OFF after you shut down. Then, before you try to power up the Mini, reach down and flip the power strip ON. Any difference?
     
  24. ha0rex
    Expand Collapse
    thread starter macrumors newbie

    Joined:
    Jan 17, 2013
    #24
    I read some forums, and found a tip, to remove the powerstrip, if I have one, because that can make differences, or cause problems. I already tried it, but no luck. :(

    I already tried to remove the power cord after shut it down, but everything is the same. :(

    ----------

    I already tried to replace the outer PSU (the white box), but no luck, everything is the same. Maybe a bad capacitor on the motherboard cause the problem?

    I had very similar issues with old, PC motherboards, long time ago.
    In that case, I found humpy capacitors on the motherboard (unfortunately in mini, everything is SMD, so I wouldn't try this), that I successfully replaced, and one of that motherboards is still running fine.

    Maybe I should take this unit, to a service station, maybe they gonna have an idea. :confused:

     
  25. OLDCODGER
    Expand Collapse
    macrumors 6502a

    Joined:
    Jul 27, 2011
    Location:
    Lucky Country
    #25
    Yes, if it's not the PSU, then a fault on the motherboard seems most likely. Off to service, i guess.
     

Share This Page