iTunes 11 crashing - first time loading

Discussion in 'Mac Applications and Mac App Store' started by mlamb64150, Nov 29, 2012.

  1. macrumors member

    Joined:
    Feb 27, 2012
    Location:
    Isle of Man
    #1
    Hi all,

    Posted this in the Apple Support Community but not getting much joy.

    Just downloaded iTunes 11, installed and upon opening the app it stalls then crashes on the welcome screen when clicking on any function.

    I suspect it might be airplay related as it seems to seek my Zeppelin Air before I even try and play anything (I get the searching for Airplay device prompt briefly on screen).

    I'm on a Mid 2009 MBP 17 running Mountain Lion.

    I've had one suggestion so far to check if the app was running in 32-bit mode. I've enabled and disabled this function and get the same result. I've also tried running iTunes after a reboot with no other applications running incase of any conflict but no joy.

    Thanks for any suggestions!
     
  2. macrumors newbie

    Joined:
    Jul 2, 2007
    Location:
    scotland
    #2
    hi - had same problem. As soon as I hit play itunes immediately quit. I checked the get info box and I was running in 32bit mode. I switched it off and itunes now works
     
  3. macrumors member

    Joined:
    Feb 25, 2008
    #3
    also happening here. where is the get info box? itunes won't open at all, but shows up in processes.
     
  4. thread starter macrumors member

    Joined:
    Feb 27, 2012
    Location:
    Isle of Man
    #4
    CMD + I when highlighting the icon in finder
     
  5. Bozley0621, Nov 30, 2012
    Last edited: Nov 30, 2012

    macrumors 6502

    Joined:
    Mar 25, 2009
    #5
    It won't budge for me. I can't figure out how to adjust the 32 bit mode, especially with it freezing.

    Edit: I figured out the 32-bit and it wasn't checked. I deleted anything in my files having com.apple.itunes.plist and that didn't help.

    Itunes freezes immediately upon opening, so I'm unable to get into preferences to see if changing any those helps.

    I think what bothers me most is that it's time to break out the Christmas playlist and I can't. :(
     
  6. thread starter macrumors member

    Joined:
    Feb 27, 2012
    Location:
    Isle of Man
    #6
    Hi all,

    Just an update for anyone having difficulty. After not getting much help to fix the issue I performed a full system restore overnight via Time Machine. Today I've downloaded and installed iTunes 11, ensuring I had no other applications running and it's worked just fine.

    I can only presume that the apps I had running the first time around required too many processes and somehow corrupted the iTunes installation/library.

    All is well now. Enjoy!
     

Share This Page