iTunes 11 splitting up albums issue?

Discussion in 'Mac Apps and Mac App Store' started by crylic, Dec 2, 2012.

  1. crylic macrumors newbie

    Jan 3, 2012
    After going through the majority of the itunes 11 threads I think I have an original issue here. So having downloaded the update and having it be in the default mode of showing all the album art, I noticed that some albums had been split up.

    An example of this is the band, Blur's live album, All the People, it will take the entirety of the album minus 2 songs and list it as one album and then take those missing 2 songs and create a separate album.

    These albums have no differences that I can discern, I've updated all the info and metadata for each song to make sure there are no differences and I still have the problem. This is being done to several albums in my itunes and can't seem to fix it.

    I'm no stranger to itunes but i've always used just the regular song list view as opposed to any of the fancier views on offer, now with this new view as default i'd love to use it but cannot because i'll never be able to listen to some of my favorite albums in intended song order because of this odd split. I am back to using song list view as it's the only way the songs appear in the proper order.

    Any help or suggestions would be great!
  2. From A Buick 8 macrumors 68040

    From A Buick 8

    Sep 16, 2010
    Ky Close to CinCinnati
    I found some of mine like that, I had to make sure the album artist was the same for each song and also had to mark all of the songs as part of a compilation.

    On a slightly separate question how do most folks handle albums with multiple CD's do you just add CD1, CD2 etc... To the album name?
  3. adnbek macrumors 65816


    Oct 22, 2011
    Montreal, Quebec
    I don't know what causes the issue but I've found a fix. Simply rename the albums, click ok, then go back and rename to their original name and the duplicate albums get combined into one.
  4. DavoteK macrumors 6502

    Jan 5, 2012
    Had this issue, normally track 1.

    Highlight all tracks from the album. Get Info. If there isn't "Album Artist" info, add it, same as the Artist normally and it should be sorted. If you have Album Artist info, remove it, normally works, or then re-add it.

    Been having this problem for a couple of years on and off, always sorts it.

    When you edit the info, add disc number of disc number to the info. Add the column to your display in list format and you'll be able to see what is called what.

    So, if you are editing CD1 of a 2 CD album, highlight all tracks, get info, put 1 of 2 and edit the album title to remove "CD1" or "Disc 1" from title, then do the same with CD2 but make that 2 of 2.

    It then looks as one album, but in track order per disc.
  5. crylic thread starter macrumors newbie

    Jan 3, 2012
    Awesome guys, this was the answer to my issue. Thanks a ton!
  6. From A Buick 8 macrumors 68040

    From A Buick 8

    Sep 16, 2010
    Ky Close to CinCinnati
    Thanks i will use this.
  7. cstiebling macrumors newbie

    Apr 5, 2013

    What I don't understand is if Itunes and Apple are so revolutionary, why can't they figure out how to group things based on similar names. It's the only music application that can't! That causes people to work after the fact. If I download music into any other application it doesn't separate them... Genius!
  8. mattg3 macrumors 6502

    Dec 8, 2010
    I have been combining cds for years on itunes and when a boxed set exists or has two discs I would always combine them into one big disc.Yes changing names of cds to one common name and combining and then changing back to original name is way to go.
    This is exactly why i wont risk upgrading to itunes 11.I sure as hell do not want to find my combined cds broken up into small cds and face a monstrous task of getting them back together.Itunes 10.whatever is fine with me.
  9. pslawing macrumors newbie

    Oct 16, 2005
    North Carolina
    I just selected the songs I want in one album and put the same data in the field "album artist" That fixed it! So each song can have a different artist, but the album has to be the same. FINALLY!
  10. wassupman8 macrumors newbie

    May 21, 2013

    I've found the answer to it!
    1. highlight all songs you would like in one album
    2. go to Get Info or command i
    3. Where it says album artist just put a space there (or you could put the artist the the general album.). If there is something already there delete it and just put a space ( or the original artist)
    4. You will find that all those songs to be in one album!

    Hope this helped
  11. mattg3 macrumors 6502

    Dec 8, 2010
    You could just change the name of the two cds you want combined into one cd.After you change the name and they combine just change name back again of the combined cd.
  12. LaPalomita macrumors newbie

    May 26, 2013
    Easier trick

    Highlight all albums that you want to merge in to one. Then go to "get info",skip over to "options", and where it says "part of a compilation' click "yes". This will merge all the albums splits together without having to do it song by song. Make sure you are highlighting the original album too when you do this or it won't work. :eek:
  13. DTinHI macrumors newbie

    Aug 24, 2013
    Change the view!

    I was going nuts with this. Did all the advice - grabbing all songs, getting info by selecting multiple songs, changing artist, album artist, blah blah. Nothing worked until I did this:

    In music view, I clicked on Album by Artist at the top. Bingo - it moved everything where it belonged. So it wasn't really splitting them, it was just showing them split when viewing by song name.

  14. GGJstudios macrumors Westmere


    May 16, 2008
    iTunes uses 4 fields to determine which albums sort together:
    • Album
    • Album Artist
    • Sort Album
    • Sort Album Artist
    As long as all tracks have matching information in those tags, the album will sort together. So for albums with various artists, put the individual artist name in the Artist field, and put "Various Artists" in the Album Artist and Sort Album Artist fields. The album will sort together. If it doesn't work initially, remove the album from your library and re-add it.

Share This Page