iTunes 11 stutters on playback randomly

Discussion in 'Mac Applications and Mac App Store' started by te4o, Jan 28, 2013.

  1. te4o, Jan 28, 2013
    Last edited: Jan 28, 2013

    macrumors newbie

    Joined:
    Jan 28, 2013
    #1
    Hi all,
    long time reader but I registered because of this issue!
    Since update to 11, iTunes behaves abnormally: stops randomly during mp3 or any audio playback, random wait, continue playing.
    System:

    Model Name: Mac Pro
    Model Identifier: MacPro5,1
    Processor Name: 6-Core Intel Xeon
    Processor Speed: 3.33 GHz
    Number of Processors: 1
    Total Number of Cores: 6
    L2 Cache (per Core): 256 KB
    L3 Cache: 12 MB
    Memory: 24 GB
    Processor Interconnect Speed: 6.4 GT/s
    Boot ROM Version: MP51.007F.B03
    SMC Version (system): 1.39f11
    SMC Version (processor tray): 1.39f11
    Serial Number (system): xxxx
    Serial Number (processor tray): xxx
    Hardware UUID: xxxx

    OS X 10.8.2 (12C60)
    Darwin 12.2.0
    SSD boot drive

    iTuines Library is on a software RAID 0 from 4 2TB WD Black Caviars, supervised by Drive Genius. They have their bad blocks but nothing spectacular.

    The FUNNY THINGS:
    iTunes Library didn't change, was working flawlessly up till a month ago, on the same system.
    I decided to revert back to iTunes 10 - had a CCC boot drive copy from early 2012. Reset to Lion - update to 10.8 , old iTunes CONTINUED RANDOM STUTTER. I was shocked. Deleted iTunes with the APP Cleaner. Clean re-install iTunes 11, updated system to latest standard - still stutter. Shocked again. Changed Library, reimported all songs, Sharing OFF, Crossfade OFF, all iOS devices offloaded, iTunes bare feet... still stutters!

    OBSERVATIONS:
    If I am working on the MAC, it seems to be OK. Left for >15 min - Stutters: SLEEP function interference??? Sleep OFF, Hybernation OFF, Hard Disks never sleep etc etc, restarted, iTunes still stutters. I am speechless!!!
    250 GB best Apple lossless classical music library, optical TOS-Link to a nice HiFi, lossless to 5 Heil AMT speakers... This issue kills me!

    Please help if someone knows what!
    Thanks++

    ----------

    One poster somewhere mentioned interference with second monitor. I unplugged my second NEC PA. Restarted and ... iTunes still stops playback randomly, to continue randomly seconds later. OK, now over to you.:)

    OK, after 3 hours of testing - it is true that iTunes doesn't stutter if I work on the computer, i.e. constant activity. But starts when I leave it playing alone. haven't tried with video files yet.
     
  2. msh
    macrumors member

    Joined:
    Jun 13, 2009
    Location:
    Redondo Beach, CA
    #2
    Any error messages in the console?

    Try moving your iTunes media/library to another non-raid drive. I suspect some kind of time-out issue with your raid set-up.
     
  3. thread starter macrumors newbie

    Joined:
    Jan 28, 2013
    #3
    1/02/13 8:35:11.914 PM iTunes[447]: 2013-02-01 08:35:11.913592 PM [AVSystemController] Stopping AirPlay
    1/02/13 11:02:21.735 PM com.apple.launchd.peruser.501[206]: ([0x0-0x11011].com.apple.iTunesHelper[299]) Exited with code: 1
    2/02/13 3:57:04.088 PM com.apple.launchd.peruser.501[206]: ([0x0-0xc00c].com.apple.iTunesHelper[262]) Exited with code: 1
    3/02/13 12:09:47.206 PM com.apple.launchd.peruser.501[193]: ([0x0-0xd00d].com.apple.iTunesHelper[241]) Exited with code: 1
    3/02/13 4:56:56.632 PM com.apple.launchd.peruser.501[188]: ([0x0-0xc00c].com.apple.iTunesHelper[236]) Exited with code: 1
    4/02/13 6:21:05.166 AM com.apple.launchd.peruser.501[189]: ([0x0-0xc00c].com.apple.iTunesHelper[236]) Exited with code: 1
    5/02/13 10:12:47.034 AM iTunes[372]: clip: empty path.
    5/02/13 10:12:49.474 AM iTunes[372]: clip: empty path.
    5/02/13 10:12:49.690 AM iTunes[372]: clip: empty path.
    5/02/13 2:53:18.085 PM iTunes[372]: clip: empty path.
    5/02/13 2:53:25.033 PM iTunes[372]: clip: empty path.
    5/02/13 2:53:37.405 PM iTunes[372]: clip: empty path.
    5/02/13 2:55:44.185 PM iTunes[372]: 2013-02-05 02:55:44.185024 PM [AVSystemController] Stopping AirPlay
    5/02/13 3:03:21.988 PM iTunes[4055]: clip: empty path.
    5/02/13 3:22:32.287 PM iTunes[4055]: 2013-02-05 03:22:32.287078 PM [AVSystemController] Stopping AirPlay

    I don't use Airplay - Optical Out instead.

    Raid used to work for 4 years flawlessly. BUt I'll try and post
     

Share This Page