iTunes 4.6 stopped working

Discussion in 'Mac Apps and Mac App Store' started by lenb, Oct 10, 2004.

  1. lenb macrumors member

    Joined:
    May 11, 2004
    Location:
    Leicester, UK
    #1
    I have the latest update of iTunes (4.6) and it has worked in the past, but it now says that I must have the latest version to access the store ......... anyone know what has gone wrong?

    lenb
     
  2. mklos macrumors 68000

    mklos

    Joined:
    Dec 4, 2002
    Location:
    My house!
    #2
    Try deleting the .plist file for iTunes and see if they works.

    Its located in your home folder/library/preferences/com.apple.iTunes.plist
     
  3. King Cobra macrumors 603

    Joined:
    Mar 2, 2002
    #3
    "...have the latest version" of what did the message say?

    First, search the forums and do an Altavista web search to see if anyone else has experienced the same problem, as well as what might have caused it. If you can't confirm that it's a problem from Apple's end, then... Make sure you've updated to Mac OS X 10.3.5 and have installed the latest Security update. If not, then update first. Then try accessing the music store. If that fails, then try reinstalling iTunes.
     
  4. lenb thread starter macrumors member

    Joined:
    May 11, 2004
    Location:
    Leicester, UK
    #4
    Thanks!

    That worked, so what caused the problem?

    Thanks

    lenb
     
  5. mklos macrumors 68000

    mklos

    Joined:
    Dec 4, 2002
    Location:
    My house!
    #5
    You probably some how got a corrupt preference file for iTunes. A few different things can cause that.

    Glad that was it!
     
  6. Lincoln macrumors regular

    Lincoln

    Joined:
    Sep 22, 2003
    Location:
    UK
    #6
    It'll probably go wrong again.

    I too (as well as many UK iTMS users) have this problem. It used to be intermittent working some days and failing others or different times of the same day.

    I haven't been able to get onto the UK store for nearly a week now. Either I get the you must upgrade problem, get the UK store front page but that will only take me to US content OR I get the US store.

    I have tried deleting preference files, loggin in out and in, restarting the Powerbook and or iTunes all to no avail. P.S. It happens on the 3 PC's in the house too.

    Apple are aware but have noy yet said anyhting publicly or released a fix. This story has been reported here: Macworld UK .

    i just hope theu get this sorted soon! :(
     

Share This Page