iTunes 4.7.1 "not responding" often

Discussion in 'Mac Apps and Mac App Store' started by MXDT, Feb 28, 2005.

  1. MXDT macrumors member

    Joined:
    Oct 19, 2004
    #1
    Any one else have iTunes crashing/locking up their system?

    It usually happens when trying to quite iTunes. It just doesn't quite. and eventually the entire system hangs cause iTunes doesn't respond. Then I'll have to do a hard reboot by holding the power button down.
     
  2. AuPhalanx macrumors regular

    AuPhalanx

    Joined:
    Apr 23, 2004
    Location:
    Wilkes-Barre, PA
    #2
    MXDT!

    That just happened to me last nite. The only difference is that it hung when I started it. EVerything else worked fine, but iTunes would not open. It showed the arrow in the dock; it showed the iTunes icon I would cmd-tab; amd it even showed as running when I checked the process viewer. Alas! It was NOT open, though. Force-quitting did nothing and when I went to restart, the system hung. I, too, had to do a hard reboot.

    I noticed that my iPod, while not syncing or anything, was connected via firewire to my Mac, which is a 1.5-MHz 15" PB. Was your iPod connected to your Mac? Perhaps that is the common thread that connects our issues.

    Hopefully, these were just one-time system farts and nothing more. All the best!

    Have fun... Tony.
     
  3. MXDT thread starter macrumors member

    Joined:
    Oct 19, 2004
    #3
    I can't recall if my iPod was connected every time it happened, the last time it was connected though... I'll keep an eye out for that... as I'm sure it will happen again just as it has been.
     
  4. blackfox macrumors 65816

    blackfox

    Joined:
    Feb 18, 2003
    Location:
    PDX
    #4
    FWIW...

    I just bought an ipod shuffle over the weekend and upgraded from itunes 4.6 to 4.7.1 ( to get shuffle functionality). After restart, with the shuffle plugged in, Itunes quit while uploading a playlist, then hung on restart, which rippled to hanging the Finder.

    After hard restart, I repaired permissions via disk utility, and at the end an itunes-related permission error was corrected. No problems since.

    Moral: repair permissions.
     
  5. AuPhalanx macrumors regular

    AuPhalanx

    Joined:
    Apr 23, 2004
    Location:
    Wilkes-Barre, PA
    #5
    blackfox!

    That may be just what I have to do. I don't think I repaired permissions since the 4.7.1 upgrade of iTunes. Damn pesky permissions! :p

    Have fun... Tony.
     
  6. MXDT thread starter macrumors member

    Joined:
    Oct 19, 2004
    #6
    My permissions have been repaired... both before and after... :confused:
     
  7. AuPhalanx macrumors regular

    AuPhalanx

    Joined:
    Apr 23, 2004
    Location:
    Wilkes-Barre, PA
    #7
    MXDT!

    Perhaps you may need to reinstall iTunes. Did you scrap your preference files? When I encounter "system farts", I like to run OnyX and let it do its thing. After a shutdown and a reboot, things get back to normal.

    Have fun... Tony.
     

Share This Page