iTunes 7 : Graphics lag

Discussion in 'Mac Apps and Mac App Store' started by redeye be, Sep 12, 2006.

  1. redeye be macrumors 65816

    redeye be

    Joined:
    Jan 27, 2005
    Location:
    BXL
    #1
    Hi,

    I just installed iTunes 7 on my 1.42 1Gb mini.
    I am experiencing major graphics lag...
    whenever i click one of the view options, or even the scroll bars only a portion of the iTunes screen updates (sometimes nothing). I have to move the window in order for it to update.

    This sucks.
    Anybody else having this issue, or some hints other than repair permissions, update prebindings or reboot (did those)?

    :mad:

    edit - a screenshot...
    [​IMG]
     
  2. Bibulous macrumors 6502a

    Joined:
    Jan 19, 2005
    #2
    Same thing with mine, though it might just be my slow system (667 G4) or that I'm also downloading a new movie (only 5 more hours!)
     
  3. redeye be thread starter macrumors 65816

    redeye be

    Joined:
    Jan 27, 2005
    Location:
    BXL
    #3
    This shouldn't be happening
     
  4. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #4
    I just grabbed iTunes 7 and I'm experiencing no lag… though I'm on a 2 GHz Intel Core Duo-equipped machine.

    Check your Activity Monitor and see how much of your computer's resources are being used by iTunes.
     
  5. redeye be thread starter macrumors 65816

    redeye be

    Joined:
    Jan 27, 2005
    Location:
    BXL
    #5
    ...
    strange

    I just quit iTunes - (i was playing with little snitch)

    Problem seems to be solved.

    I'll post back when it happens again, hope I don't need to.

    Edit: it started again - changed some "part of compilation" tags to try to understand the album browsing thing...
    It could be iTunes doing some background stuff that causes this.

    Edit2:
    I'm using menumeters and I see no hogging of CPU nor RAM. It does use more than previous versions from time to time
     
  6. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #6
    Is it getting album art or analyzing your tracks for gapless playback? These two inital things could cause it to lag the first time you run it.

    Coverflow did back when it was a standalone app. When it was done it was fine.
     
  7. redeye be thread starter macrumors 65816

    redeye be

    Joined:
    Jan 27, 2005
    Location:
    BXL
    #7
    That is indeed what I now think it is.
    It's working fine again now :).
    I like it.
     

Share This Page