iTunes 7 Video problem on PC

Discussion in 'Mac Apps and Mac App Store' started by KevKaos, Sep 20, 2006.

  1. KevKaos macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #1
    OK, I know this this question involves a PC, but I can't buy my Mac yet and my new video iPod is on the way. With that said, I downloaded and setup iTunes 7 on my PC. I got an account and I have downloaded some TV programs and podcasts.

    When I start playing either type of video, it comes up perfect. It has the little semi transparent controls in the bottom part of the window. After a few seconds, it looks like those controls are supposed to disappear, but when they do, my video changes to something that looks like a color negative image. If I move my mouse into the window so that the controls come back up, the video returns to normal.

    If I choose to use the mini player, (I think that is what the option is called), the controls are in one window and the video playback is in a separate window, the video comes up as the same sort of color negative image and stays that way. Any thoughts? A driver problem maybe?
     
  2. KevKaos thread starter macrumors 6502

    Joined:
    Sep 1, 2006
    Location:
    Baltimore, Maryland USA
    #2
    Turns out that the problem was indeed a video driver issue. I updated my Nvidia driver, rebooted the PC and the video problem seems to have gone away.
     
  3. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #3
    Thanks for posting your solution, so that future people with similar problems may save themselves some time. Good forum etiquette :cool:

    Cheers.
     
  4. scudsone macrumors newbie

    Joined:
    Sep 28, 2006
    #4
    I've had the same problem but updating my video card driver was no help. however the following, which came from "boatracer" at ipod lounge works great for me:

    "Open the Quicktime Preferences (open the quicktime player and goto Edit>Preferences>Quicktime Preferences)

    Goto the Advanced tab.

    Under Video uncheck the box that says "Enable Direct3D Video Acceleration".

    Apply the change and close and restart itunes. Hopefully this works for you."

    here's the thread on ipod lounge:
    http://forums.ilounge.com/showthread.php?t=174761
     

Share This Page