iTunes 9 on Windows sucks

Discussion in 'Mac Applications and Mac App Store' started by at&t, Sep 9, 2009.

  1. macrumors newbie

    Joined:
    Jul 9, 2009
    #1
    Let me be the first to complain.

    Ok, so I downloaded the new iTunes 9.

    The same problem happens to me as in other versions of itunes on Windows - when I import a CD, the track names get the track numbers before them. Ok, so I delete the track number from the track name for EVERY track in the library but now whenever I click on the song name it reappears. if I click twice.. two track numbers appear.. click 5 times, 5 track numbers appear!

    How do I stop this :mad: I had no problems on Mac but on Windows starting since iTunes 8 I had this issue and now even if I delete the track number from the song it will reappear again if I play it!

    I tried everything and it won't help the problem. The same problem occurs for me on all of my PC's that run iTunes 8 and now it is even worse with iTunes 9.

    I found some resolutions for this on the Mac but I did not find anything on Windows. If there is no way to fix it then I will dump iTunes.

    Pathetic.

    Here is a screenshot of what I am talking about:

    http://img525.imageshack.us/img525/5498/itunesl.jpg

    Sorry for bad english.
     
  2. macrumors 68020

    dccorona

    Joined:
    Jun 12, 2008
    #2
    workss fine for me, what version of windows are you using (I'm on 7)
    although, maybe I'm not seeing it because I don't import my CDs on the WinPC
    I do it on the mac, and stream from there to the PC downstairs (which has the bigger hard drive, so really, I'm kinda being counterproductive haha)

    BTW, thanks Apple, this is much easier now! Home sharing!

    As far as I can tell, its with the way windows handles the files. Files are called 01_Imagine, etc, but that 01 is stripped out by iTunes. For some reason its not doing that
     
  3. macrumors 68020

    SeaFox

    Joined:
    Jul 22, 2003
    Location:
    Somewhere Else
    #3
    I don't have that problem, and I'm not even using an officially support configuration! I have iTunes 8.0.2 running on Windows XP x64, which is done by hacking the Vista 64 bit installer.

    Maybe it's your computer that sucks and not iTunes. :p

    Nah, it sounds like your library file got borked when you updated to iTunes 8, since that's when it started.
     
  4. thread starter macrumors newbie

    Joined:
    Jul 9, 2009
    #4
    No, my computer is just fine. In fact, after doing more research it is clear that the problem is more on the Mac side than on Windows but on the Mac side there is a solution using Terminal to fix it.

    On Windows we do not have that so I guess I am screwed. I am NOT going to rename my 2,000 songs by hand because Apple screwed something up and they did because if you google you will see that there are tons of people in my situation.

    I did not upgrade my library from iTunes 8. I actually started with a new one, hoping that this issue would finally be fixed. But no, same **** on all off my computers.

    I am done with iTunes, this is pathetic.
     
  5. macrumors 6502

    Joined:
    Sep 7, 2007
    #5
    Really? I'm actually finding the exact opposite on Windows 7. Itunes 8 was complete garbage, this newer version is actually scrolling through my apps smoothly and not taking forever to load.
     
  6. thread starter macrumors newbie

    Joined:
    Jul 9, 2009
    #6
    Look at this!

    http://img30.imageshack.us/img30/690/58837228.jpg

    Absolutely pathetic. I like the new version and this is the ONLY problem I have with it. However this will also be the reason why I will dump it.

    I have this problem on 4 machines running Windows 7, Windows Vista and 2 XP.
     
  7. macrumors member

    Joined:
    Nov 14, 2006
    #7
    I just posted in another thread about iTunes 9 in windows.. It's the worst yet. It used to pause randomly on me in v8 but now in v9 that has been fixed..instead it overall just sucks now.

    Anyone get the gaps in library when deleting something? Or maybe half your damn album names are now truncated. Total piece of **** software from 8 to 9.
     
  8. macrumors 6502

    Joined:
    Jan 1, 2008
    Location:
    El Paso, TX
    #8
    Same exact thing happened to me! All the track numbers would duplicate themselves however many of times whenever I would click on them. Happened to EVERY single track I clicked (which was every track in the list). Big pain.
     
  9. macrumors 6502

    Joined:
    Nov 28, 2008
    #9
    Well, it's on windows.... :p

    I have not had any of these problems, but I hypothesize that you either
    a) Have a bad install.
    b) Have some sort of **** drive/drive configuration that is doing something stupid.
    c)Upgraded from 8 to 9, not using a clean install, which everyone knows is usually required for best performance.
    d) Have messed up audio files. (Rip using some other program. WMP? I don't care... If that fails, try fixing the mp3 tags with "mp3tag", google it.)

    And when the day comes when each one of you produce a better piece of cross-platform software with all of the features, functionality, etc., THEN you can bitch about bad programming. Until then, post "I have a problem in iTunes", not "this program is garbage:mad::mad::mad::mad::mad:"
    [/hate]

    :apple:


    oh yeah, and at&t... define "everything" when you say " I have tried everything"....
     
  10. macrumors 68020

    Joined:
    Sep 24, 2002
    Location:
    Utopia
    #10
    iTunes on Windows is like MS Office on Macs--they suck!
     

Share This Page