iTunes alias to external library not working on new MacBookPro

Discussion in 'Mac Apps and Mac App Store' started by squidz, Aug 15, 2009.

  1. macrumors newbie

    Joined:
    Aug 15, 2009
    #1
    I have been playing iTunes from an external drive for a couple of years. I got a new MacBookPro and have set up my alias "iTunes Music" to point to the external drive.

    However, none of the music shows up. I can't figure why. I even deauthorized my old MacBookPro, which I really didn't need to do cuz the new one was number 5.

    But nothing...

    Anyone know the remedy? I even tried to drop my iTunes prefs from the old MacBookPro, but the Genius pref kept saying it was in use even when iTunes was shut down.
     
  2. macrumors 6502

    Joined:
    Feb 9, 2008
    #2
    The pointing I think will just add new music to that location. If you want to get the music into itunes you then have to import.

    If you want to keep everything the same:

    Exit iTunes on both the old and the new.
    Delete the iTunes Library.itl and .xml files on the new computer.
    Copy over the itunes.xml and itunes.lib files from the old computer.

    I would also also copy all of the folders, except for the "previous itunes library" folder. This should include the "Album artwork" folder, possibly a Genius folder and maybe and applications folder, if you also have an iphone.

    I have done this myself a couple of times.

    Also, I highly recommend doing a library consolidation on the old computer first. Especially if you purchase music. If for some reason itunes was unable to connect to the external drive when purchasing music it would put them in you computers hard drive in the music/itunes folder as opposed to the external drive. Consolidating makes sure all of the music is stored in the place you have designated in the preferences. Also, on the new machine you want to make sure that you have the box checked off to copy new music to the itunes folder if you want all additions to be placed on the external drive.
     

Share This Page