iTunes annoyance - cannot combine songs into album

Discussion in 'Mac Apps and Mac App Store' started by Tumbleweed666, May 9, 2009.

  1. macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #1
    I have imported an album from CD but iTunes INSISTS that track one is one album, and tracks 2-4 are another - though it gives both albums the same name. So the "second" album has tracks 2-4 of 4 and the first, 1 of 4. I have done all the usual stuff, selected them all and bulk changed / retyped artist, album name , cover art etc. Anything I might be missing?
     
  2. macrumors 68020

    Kardashian

    Joined:
    Sep 4, 2005
    Location:
    Britain.
    #2
    Make sure they have the exact same album name, and album artist and track artist are the same. And disc number 1 of 1 is all marked etc.
     
  3. thread starter macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #3
    yep, yep yep yep all identical - all bulk changed at the same time and if I page through individually the only detail that changes is the track name.
     
  4. macrumors 6502

    hanschien

    Joined:
    Oct 2, 2006
    Location:
    Houston, TX
    #4
    I have noticed that special characters in the album name caused this in iTunes.
     
  5. thread starter macrumors 68000

    Joined:
    Mar 20, 2009
    Location:
    Near London, UK.
    #5
    Fixed it.
    maybe as you say something non visible was there I deleted the album name, replaced it with 'junk' and it went to one album, then retyped the name. Possibly I did cmd-x and v before to re-enter it so that would have copied across any invisible characters in the name.
     
  6. macrumors 65816

    Galley

    Joined:
    Mar 24, 2008
    #6
    This has happened to me a few times. I ended up renaming all tracks to something else, and then going back to the original name.
     
  7. macrumors newbie

    Joined:
    Sep 3, 2010
    #7
    Merging iTunes songs into a Single Album

    I was having this problem too. Bulk-renaming sometimes fixed the problem, but sometimes did not. However, I did find a solution: Select all the songs you want to be in the same album, go to File>>Get Info, click on the "Options" button, check "Part of a compilation," and select its drop-down menu to "Yes." Hope this helps.
     
  8. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #8
    Yet another year-old thread revival as the first and only post by a newbie! What's the deal? By the way, you don't need "part of a compilation" checked as long as you have matching data in Album and Album Artist. As long as those tags match exactly, the album will sort together. If they don't match, even checking "Part of a compilation" will not cause them to appear as one album.
     
  9. macrumors newbie

    Joined:
    Sep 7, 2011
    #9
    Another newbie here bumping a year-old thread!

    Thanks emf0 for the tip, I've tried everything to sort this, tried everything. Ticking 'Part of a compilation' sorted it! Don't think GGJstudios knows what they're talking about!
     
  10. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #10
    I know exactly what I'm talking about. iTunes uses Album and Album Artist to determine what constitutes an album. It also uses Sort Album and Sort Album Artist to determine how that album is sorted. If you have matching data in those fields for all tracks, the album sorts together, whether you have "Part of a compilation" checked or not. You might take some time to learn your way around the forum and understand your software before you start criticizing others who take the time to answer questions.
     
  11. macrumors newbie

    Joined:
    Sep 27, 2011
    #11
    resolved issue

    yeah had same annoyance and can confirm GGJstudios knows what they're talking about - in fact, thank you for the tip.

    make sure ALBUM ARTIST and ALBUM are identical - mine was screwy because I had ARTIST matching, but blank field for ALBUM ARTIST.

    part of compilation field did nthg for me.
     
  12. macrumors newbie

    Joined:
    Nov 17, 2011
    #12
    Need to Consolidate Albums in iCloud with compilation

    So - I too have discovered that the "Compilation" option under Get Info will indeed cause iTunes to treat the various tracks as part of the same album, even if they have different artists. (Not sure why this isn't the default - but oh well)

    What I need to do now, is figure out how to treat them all as a single Album in iCloud. For example - I have eight "Singers and Songwriters of the Seventies Albums" - about 12-20 tracks per album, 127 Tracks. After "Shift+Clicking" all of the tracks, clicking on "Get Info" and then under Options setting them as "Part of a compilation" iTunes now treats them as only eight albums (used to treat them as 127) - but, on my iPhone, the tracks are all treated as separate albums - it effectively turns "ALBUM VIEW" into "SONG VIEW".

    Here is one approach - that I just verified works.
    Step 1 - Select your Album in iTunes - go to it in finder (hopefully all in a single folder) - Save it to a safe place on your system (just save the folder somewhere else - you'll be reopening it in a few seconds to import it back in)

    Step 2 - Delete (from within iTunes) the album. Make sure you click "Also delete these songs from iCloud"

    Step 3 - watch your iPhone - wait for the music to by "Cloud Removed" from it. (Not sure if this is required - but I figured better safe than sorry - the deletion happened _very_ fast in my case - seconds.

    Step 4 - Import your Music back into iTunes from the "Saved" folder. Via the CMD+O - Open the Folder that you saved your music in. Opening the folder actually imports the entire thing.

    Step 5 - Option 1 - This part I'm not sure of, but what I did is _quickly_ select the tracks, and then Get Info, and then Options, and then "part of a compilation" - Yes. Now - it was _already_ set to Yes, so I'm not sure if (A) it was required I do it a second time, and (B) how much time I had to do it before the cloud syncing took place.

    Step 5 - Option 2- I tried a second time with a different Album, (that I had already identified as a compilation before deleting from iTunes/Cloud) - and this time I did NOT select them as a compilation - iTunes somehow already knew they were - not sure if it was because of metainfo in the songs, in the Library, or because I imported them from a single folder - but it did it properly.

    Note - any experimentation may need to take place around Step 5 to get it _just_ right.

    Step 6 - Wait for 5-10 minutes while iTunes matches/uploads songs from your album, and then it should appear on your iPhone/iPad as a downloadable entitity - as a _single_ album. If you have a high "match" rate, then (in my case) this may only take a minute or so.

    Step 7 - Click on "Download Album" - and the music should come down, and be available to you as a single entity.

    And that is how to get your Albums compiled into a single entity on both iTunes and the Cloud (and then all the devices you download from)

    I have to say i am very, very impressed with iCloud + iTunes so far. Doing everything I could ask it too.
     
  13. macrumors 68040

    ntrigue

    Joined:
    Jul 30, 2007
    #13
    It was a space after the album name. Happens a lot.
     
  14. macrumors newbie

    Joined:
    Nov 17, 2011
    #14
    Actually - you are both correct. If you select "part of a compilation" - then iTunes changes the artist to be "Compilation" :)
     
  15. GGJstudios, Nov 17, 2011
    Last edited: Nov 17, 2011

    macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #15
    That is absolutely false. iTunes does NOT change the Artist at all, if you select "Part of a complilation". Where do you people come up with this nonsense?
    ScreenCap 1.PNG
     
  16. macrumors newbie

    Joined:
    Nov 17, 2011
    #16
    Changing the Artist to "Compilation"

    The Metainfo Artist isn't changed, but the Artist in the File Structure is - if you notice, when you click on Options/"Part of a Compilation" - it moves the song into the directory structure underneath "Compilations".

    So - iTunes groups songs underneath an "Album" if their Album Name and Artist match - but, in an Album where all the artists are different, you end up with a different Album per Artist. So - iTunes solves this by creating a "Compilations" artist directory, and places all the compilation albums underneath that.

    It is a pretty good solution.
     

    Attached Files:

  17. GGJstudios, Nov 17, 2011
    Last edited: Nov 17, 2011

    macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #17
    That's only if you let iTunes manage your music files, and it has no bearing on how things sort within iTunes.
    No, it isn't. First, you have both the artist name and the song name in the Name field. Not good.
    That's because you don't have the Album Artist field matching for all songs in the album.

    You should have the following:

    Artist: Dire Straits
    Album Artist: Various Artists
    Name: Sultans Of Swing
    Album: Singers And Songwriters 1978-1979
    Disc #: 2
    Track #: 2​
    Then you have "Part of a compilation" checked, because "Singers And Songwriters 1978-1979" is part of the same compilation as "Singers And Songwriters 1970-1971", even though they are different albums.
     
  18. macrumors newbie

    Joined:
    Nov 17, 2011
    #18
    Combing Songs into an Album

    Thanks for clarifying and setting me straight - even after googling this topic for several days, your description is the clearest and most useful I've been able to find on the web - hopefully others will trip across it and find it as useful as I have.

    Now that I've got it clear in my head that "Album Artist" + "Album" is what instructs iTunes to treat something as an Album - what is the purpose of "Part of a compilation" - I've tried setting it to "No" and "Yes" - but in neither case does it seem to impact how iTunes treats it. For some reason, clicking this option early on seemed to sort the albums into separate categories (Did it change the Album Artist?) - but I can't get the behavior to repeat. All it seems to do is (as you said) - cause iTunes to move the music into a new folder underneath compilations.

    Thanks for your help and insight!
     
  19. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #19
    Clicking "Part of a compilation" will never change any metadata. It's useful when you have a situation like your "Singers And Songwriters" collection. In that collection, you have multiple different album names, which would normally sort as different albums. If you check "Part of a compilation", those albums will stay together, even though the album names differ.

    As far as moving the files, that only occurs if you let iTunes manage your music files. Some don't care how the files are organized, but some, like me, have an organization that we don't want iTunes to mess with, so we uncheck both of the following boxes in iTunes > Preferences:
    iTunes > Preferences > Advanced > organize & copy checkboxes.PNG
     
  20. macrumors newbie

    Joined:
    Dec 31, 2011
    #20
    Sometimes the above suggestions do not work. The instance I'm encountering is where song data was changed by a trial version of BPM'r. Removing that from the BMP and comments fields didn't seem to help.
     
  21. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #21
    What, exactly, is your problem?
     
  22. macrumors newbie

    Joined:
    Jan 20, 2012
    #22
    It worked for me actually...was trying everything to get an album together instead of it looking to albums. Part of Compilation worked for me after trying to rename everything several times.
     
  23. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #23
    Checking "Part of a Compilation" does NOT change the Artist tag at all.

    To make an album sort together, all tracks must have identical information in the following fields:
    • Album
    • Album Artist
    • Sort Album
    • Sort Album Artist
    If you have matching information in those fields, the album will sort together. If it's not, try deleting the album from the iTunes library (keep the files), and then re-add it.
     
  24. macrumors newbie

    Joined:
    Jan 24, 2012
    #24
    Another first time n00b poster with a solution

    1. Highlight all tracks that should be on the same album but are not.
    2. Get Info for the selection.
    3. Make sure the Artist and Album are the same for all the selections. Odds are, if they're not showing up as the same album, either the Artist or Album field is blank.
    4. Enter the blank field as it should be reflected.

    That should do the trick. At least, it just did for me.
     
  25. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #25
    Did you bother to read the post just before yours? Or the several other times this exact same information was posted in this thread?
     

Share This Page