iTunes: Artist not showing up on device sync page.

Discussion in 'Mac Apps and Mac App Store' started by coasterider, Jul 3, 2010.

  1. macrumors regular

    Joined:
    Jun 29, 2010
    Location:
    Washington, DC Orange County, CA
    #1
    For some reason one artist, this happens to be The Beach Boys, is in my library, 6 albums 57 songs, but does not show up on the checkable sync page so I can put it onto my iPhone. All other artists are showing up, what is different about this one artist?
     
  2. macrumors 6502

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #2
    Similar thing here. Fleetwood Mac is not in the checkable list of artists to sync. I have created a playlist for this artist. You're not alone.
     
  3. thread starter macrumors regular

    Joined:
    Jun 29, 2010
    Location:
    Washington, DC Orange County, CA
    #3
    Did you download them or rip it from a cd? I ripped my Beach Boys from the cds. Maybe that makes a difference. Once you put it as a playlist, where you able to remove it and keep the artist there?
     
  4. macrumors 6502

    allan.nyholm

    Joined:
    Nov 22, 2007
    Location:
    Denmark
    #4
    I downloaded their greatest hits from iTunes a while back. It was just recently that I wanted to have them synced to my iPhone by using the new artist sync that I noticed it.

    After I created the playlist I still see no sign of Fleetwood Mac on the artist sync page. I haven't tried removing the playlist yet. I've just settled with this solution.
     
  5. macrumors regular

    Joined:
    Feb 21, 2010
    Location:
    Good ol' Germany
    #5
    i guess you will find it somewhere else as a greatest hits collection might have the compilation-tag. check if this is the case and remove it.

    Regards,
    Baguette
     
  6. macrumors newbie

    Joined:
    Jul 16, 2010
    #6
    Try this it worked for me.

    I went to the Get Info page for the the Album and found Album artist was empty even though Artist was there. So I added in Album Artist and it appeared on the iphone sync page.:)
     
  7. thread starter macrumors regular

    Joined:
    Jun 29, 2010
    Location:
    Washington, DC Orange County, CA
    #7
    Figured it out, they were checked as compilations so it was not showing up as an artist, unchecked and now it works fine. Thank you Labaguette!
     

Share This Page