iTunes Bug??

Discussion in 'Mac Apps and Mac App Store' started by rickvanr, Jan 29, 2004.

  1. rickvanr macrumors 68040

    rickvanr

    Joined:
    Apr 10, 2002
    Location:
    Brockville
    #1
    Hello, i have been iTunes since v1. And ive had an iPod since they came out. Lately I have noticed that in iTunes some of my songs are disappearing. They arent disappearing from my iTunes library, but from the computer. I'm not deleting them, they are just gone.

    so i have a few questions...
    1) is there an easy way to tell which songs are in ur library. when a song is missing i get a little circle with an explanation mark inside of it. how do i check for songs like that.

    and secondly, has anyone else been having this problem?
     
  2. johnnyjibbs macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #2
    Recently when I transferred songs to my brother's iPod, some of them didn't show up, even though we had it set to auto-update. Is this what you mean? If the songs are in the library they should show up in the list. If they have question marks next to them (I have never experienced this), what happens when you right click and choose "Show song file"? Is there a file there?
     
  3. rickvanr thread starter macrumors 68040

    rickvanr

    Joined:
    Apr 10, 2002
    Location:
    Brockville
  4. johnnyjibbs macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #4
    Do you have the "Keep music library organised" option ticked? And you haven't messed about with the music library folder?

    Some file must have corrupted. You may have to re-rip.
     
  5. rickvanr thread starter macrumors 68040

    rickvanr

    Joined:
    Apr 10, 2002
    Location:
    Brockville
    #5
    it looks like this
     

    Attached Files:

  6. rickvanr thread starter macrumors 68040

    rickvanr

    Joined:
    Apr 10, 2002
    Location:
    Brockville
    #6
    i do have that option selected. i dont mess with the files that are vanishing...
     
  7. johnnyjibbs macrumors 68030

    johnnyjibbs

    Joined:
    Sep 18, 2003
    Location:
    London, UK
    #7
    Sorry, I can't help you. I guess something has gone wrong, either a bug (which no-one else has reported, so I'm not sure), or a glitch has occurred with your hard drive. You must have had some data loss or corruption. Maybe someone else can help.
     
  8. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    I don't know if this will help, but try repairing permissions. Also, open Terminal and type

    sudo periodic daily weekly monthly

    followed by your password, then wait patiently (2-5 minutes, no visible output).
     
  9. Thanatoast macrumors 6502a

    Thanatoast

    Joined:
    Dec 3, 2002
    Location:
    Denver
    #9
    this has happened to me as well. not recently though. and my friend had it happen on his pc, but i've never been able to figure it out.
     
  10. Phatpat macrumors 6502a

    Phatpat

    Joined:
    Jun 15, 2003
    Location:
    Washington DC
    #10
    Same thing happened to me. The files were still on my computer, but the path to it got messed up or something. I added the song to my library again, and it worked. Don't know why it happen, but it hasn't happened recently.
     
  11. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #11
    Hmm, I just noticed that on mine too. Underworld's dubnobasswithmyheadman has disappeared from my music folder. Not good, because I like that album.
     

Share This Page