iTunes changing track info on its own?

Discussion in 'Mac Apps and Mac App Store' started by tubedogg, Aug 9, 2005.

  1. tubedogg macrumors regular

    Joined:
    Dec 18, 2003
    #1
    I am having a problem with iTunes 4.9 on OS X.4.2.

    I have about 28000 tracks comprising about 147GB of files in my library. I had a problem a couple months back with an album of MP3s where I would make changes to the tags, and immediately upon playing the songs or attempting to make further changes to them, they would revert to their prior tags. Try to change them back, and they don't "stick"; it acts like it works, then the same thing happens again. I trashed that album and haven't had that problem again, until now.

    Last night I ran into the issue with another album, and I trashed it and restarted the computer. Today I modified many tracks info (giving them all disc numbers) and tonight, I played one song, which worked fine, then when iTunes moved to the next song, it changed the track info. So I double-clicked to start the next track, and it did the same thing. I stopped the playback, and restarted iTunes. Now it's working fine again, with the exception of those two tracks. Last time this happened it affected every track in the album; this time it seems to only be affecting these two tracks.

    Does anyone have any clue what could be going on here? I thought maybe it was a permissions issue but I have checked the permissions on these files and they seem fine. My other thought was the library data file is somehow getting confused or something, but I'm curious as to where the old track info is coming from -- it's changing, for example, the track name to "Album -Track#- Song Name" and setting the genre to what it was tagged with when originally imported.

    Any help would be appreciated!
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    I had the same problem and I couldn't find the cause. However, I worked out that converting them (even to the same file format) solved it. :)
     

Share This Page