iTunes does not display Asian characters correctly.

Discussion in 'OS X' started by akbc, Dec 21, 2008.

  1. macrumors 6502

    Jul 11, 2008
    Hello everyone.

    I usually keep my music files on my PC and stuff, but since I was thinking of getting rid of it, I transferred all my music files into my MBP.

    So I transferred it via a USB Drive, and what do you know, iTunes show some of my Korean and Japanese songs with broken-looking weird scribbles.

    It happens to only certain songs, and I really am confused.

    As you can see in the attached picture, some displays the correct characters, but some just looks weird. Like the bottom three songs show correctly, but not some of the top ones or the highlighted one.

    However, both my iPhone and my iPods in the past showed ALL Korean/Japanese charcaters without a single problem.

    Is there any language pack that I'll need to be installing?
    Or is there some kind of encoding within the iTunes?

    I am currently using the latest build/version of the iTunes on Mac OS X Leopard running on Unibody MacBook Pro 2.53Ghz.
    The MacBook Pro is also up-to-date with any of the latest updates via Software Update.

    I should be asking at the iPod and iTunes section I guess, so if it really seems like it's an absolute must that I post in the iTunes section, please let me know.

    Any help would be greatly appreciated,
    thank you in advance.

    Attached Files:

  2. macrumors G4


    Nov 3, 2005
    I can type Japanese characters in emails on my iTouch...

    I did so today.
  3. thread starter macrumors 6502

    Jul 11, 2008
    Yeah, the Korean/Japanese characters show perfectly fine on my iPhone like I said, I can type/read with no problem.

    It's the iTunes that's messing me up, and I really don't know what to do :(

    Just in case anyone is wondering, I guess I'll put down how I fixed it.

    It was rather.. pretty simple. I just went to the "Get Info", and checked off all langauges except for Japanese and Korean. Then I restarted iTunes, and voila. It's done.

    All languages show up correctly.
  4. macrumors regular

    Dec 22, 2008
    ive got the same problem, but i dont really understand your resolution..
    there is no languages in 'get info' (or is there another get info tab im unaware of?)

  5. macrumors newbie

    Sep 14, 2009
    I'm also having the same problem, can someone explain a little more in depth. I don't see any language options under "get info". I'm running snow leopard and itunes 9.:confused:
  6. macrumors newbie

    Dec 6, 2009
    having same problem

    I'm having the same problem....and I couldn't find a language selector in "Get Info" either.

    All my Korean songs displayed fine on my laptop running Windows XP but when I transferred my library to my new PC running Vista, some of the Korean songs show up as jibberish in iTunes.

    I've tried reinstalling iTunes and I've tried reimporting the songs and nothing seems to work. It's not a matter of installing language packs or IMEs -- I've done that and my PC displays Korean fonts just fine, it's just inside iTunes that I'm having this problem and only with some of the Korean songs, not all the Korean songs.

    Any help would be appreciated.

  7. macrumors regular


    Jun 5, 2007
    Torrance, CA

    Somebody help on this please. I have the same issue.

    On top of this, something weirder is happening. When sharing libraries in my home network, I can see the windows itune's song titles fine from my other macs but when I drag and drop, it turns in to garble. When transferring or copying files, initially the song info is a lighter shade (fonts looks perfect at this point) when the copying is complete and the song info turns dark (this is when the fonts get all messed up). Must be an OS X thing.

    I've also noticed that (like someone else posted) not all files are like this. Some transfer fine. I did notice that new songs are more garbled than the older songs. My latest batch of newest songs are ALL messed up. Is there a "newer" Korean font that people are using that can be read on the web and through networks but is not compatible when stored in a mac?
  8. macrumors 6502a


    Sep 8, 2006
    Tokyo, Japan
    No solution here but another one with the problem. I want to have my OS language in Japanese, but it corrupts all my song names in iTunes if Japanese is the enabled system language. The songs are rendered correctly until I play them, and then they become corrupted. This happens especially if there are some non-letter characters in the song title, such as an apostrophe. Very annoying.

    Anyone with a solution please chime in....
  9. macrumors regular

    May 31, 2009
    I made a similar post on apple discussion and came to a solution to my problem not displaying thai font on itune,

    it's all about the ID3 Tag.

    the link is here

    open up the ID3Mod app, load the itune, and select your music change to the correct language code, if it is displaying the correct one click save on it.(unable to undo once you save, so make sure you got the right one)

    and on itune side, once you get info on that song it will update the language code.

    hopefully this help.
  10. macrumors regular


    Jun 5, 2007
    Torrance, CA
    Not a real solution, but it's working for me without using any other app.

    Mine is doing the opposite. When my OS is set to English, it's all messed up. When I switch to Korean, it still shows garbled until I click on the song then it magically changes to the correct font. :confused: It displayed correctly for Korean, Japanese and Chinese character songs that I have. Must be a font thing. When I switch back to English it reverts back to the garbled font. Actually, all songs display correctly until I click or play it.

    I haven't tried the ID3Mod yet, but I'll give it a try so I don't' have to switch back and forth from English to Korean system language.
  11. macrumors regular

    May 31, 2009
    there's no need to switch between language,
    my major is english,
    but on itune specific language song name will display in their own font such as thai japanese so on~
  12. macrumors regular


    Jun 5, 2007
    Torrance, CA
    I don't think you understand the problem... "itune specific" is what you're talking about, such as songs that are bought in itune store or ripped in itunes and id tags generated within itunes.

    What we are talking about is transferring songs from a PC to a Mac that are not "itune specific".
  13. macrumors 68040


    Aug 28, 2009
    I have had this issue with some of my music. Since most of it is from CDs it isn't very often. When I do, I simply retag. There are various encoding types for Asian languages, sometimes the Windows ones simply don't come through.

    For example, I often hop on the Yahoo Japan Chat Rooms. Probably 50% of the users chatting are sending through Japanese encodings that get display as garbage for me.

    There are even some websites where I simply cannot read the content, no matter which encoding I choose in the browser.

    Since most of my music is Japanese, and I can read and write Japanese (and Chinese) I simply retag them myself.
  14. macrumors regular


    Jun 5, 2007
    Torrance, CA
    For those of us that have a large collection of songs from a PC, this is not an option as it will take too long. You either have to find the original song before the garble or know the song by heart to change the tags. Not practical.
  15. macrumors 68040


    Aug 28, 2009
    Fair enough. In situations like that there aren't many practical solutions. Good luck to you.
  16. macrumors 65816

    Nov 14, 2008
    Yeah, that's what I had to do with a number of my Chinese songs when I migrated from PC to Mac. It's a PITA, but apparently no better way of tagging your mp3s correctly. Fortunately I had all their EXTERNAL 'tags' correctly so I could just copy-paste those into the internal tags...
  17. macrumors newbie

    Sep 14, 2011
    Well I think I figured out how to fix this even though this thread is over a year old. The old method of "get Info" doesn't work anymore on newer ones. Someone had directed me to ID3Pro v2.0 on macupdate and it worked for me. Basically you load the songs into ID3Pro by searching the folder you downloaded the osngs to and in the encoding you choose MacJapanese (for japanese songs) and hit save. It'll go thru the ID3 tags and rename them in the proper format and then relaod the songs into iTunes and voila its good.
  18. macrumors newbie

    Jan 24, 2012
    iTunes update

    So I recently applied an update to my iTunes and restarted it. Now none of my Japanese characters (which showed up fine before the update) are showing up. I've tried switching the language and restarting, that didn't work. I know my computer is up to date on language settings because I can view asian characters anywhere else. It's just iTunes. Does anyone know how to fix this? Or am I seriously going to have to retype in the title, artist and album for my over 450 Japanese songs??? :(:confused:
  19. macrumors 6502

    Oct 29, 2010

    And make sure you keep a copy of your music files on the PC side, in case something goes wrong, you won't have to go through each song and figure out which is which. (been there...)

    Good luck :D

    just noticed this thread is over 3 years old....
  20. macrumors newbie

    Nov 3, 2012
  21. lxunyc, Dec 2, 2012
    Last edited: Dec 5, 2012

    macrumors newbie

    Dec 2, 2012
    Thanks for this link. This is exactly what I've been looking for.

    However, I'm having problem installing the the app on my PC. Did you have this problem? (And, if so, how do you bypass it?)

    ETA - Never mind. Figured out after some further research. Thanks all the same!
  22. macrumors member

    Nov 27, 2012
    Washington, DC
    This didn't work for me. So sad... I guess I'll just use ID3Mod2.

    Does anyone know how to make iTunes refresh all songs in the library?
  23. Bomb617, Feb 25, 2015
    Last edited: Feb 25, 2015

    macrumors member

    Jul 25, 2012
    I am having this problem in OSX Yosemite, would it still work?

Share This Page