iTunes freezes when playing Videos from Podcast and movies

Discussion in 'Mac Apps and Mac App Store' started by kitki83, May 13, 2008.

  1. macrumors 6502a

    Joined:
    Mar 31, 2004
    Location:
    Los Angeles
    #1
    Hello everyone,

    I am having problems with my videos. On both podcast videos and my collection of movies causes itunes to freeze. I get the rainbow circle. Unable to force quit. Basically I have to do hard shut down, not sure what causes it. The mouse moves but the whole desktop does not respond and I can hear the audio but thats about it.


    thanks
     
  2. thread starter macrumors 6502a

    Joined:
    Mar 31, 2004
    Location:
    Los Angeles
    #2
    Ok having serious problems, my itunes seems sluggish and staggering with music. I ran Onyx and did repair permissions. Not sure what else to do but to uninstall itunes and redo my whole library. Someone has any idea why itunes freezes with videos and is slow with music.
     
  3. macrumors 6502a

    cloudnine

    Joined:
    Jul 3, 2006
    Location:
    San Francisco, CA
    #3
    I've been having the same exact issue for the past, say, 4-5 days? I have no idea what I did differently, but every time I go to play a song or movie or video, it freezes for 10-15 seconds... then plays for 3-5 seconds... then freezes for another 10-20 seconds. It's really annoying because it does it for anything and everything I try to play.

    If I figure out why it's doing it, I'll let you know. :/
     
  4. thread starter macrumors 6502a

    Joined:
    Mar 31, 2004
    Location:
    Los Angeles
    #4
    Was there a recent Itunes updates within the last few weeks?
     
  5. macrumors 6502a

    cloudnine

    Joined:
    Jul 3, 2006
    Location:
    San Francisco, CA
    #5
    Eh... 7.6.2 was released on April 2nd... so I don't think it was that :/
     
  6. thread starter macrumors 6502a

    Joined:
    Mar 31, 2004
    Location:
    Los Angeles
    #6
    Might be that, I dont do updates after a month they have been release.
     
  7. thread starter macrumors 6502a

    Joined:
    Mar 31, 2004
    Location:
    Los Angeles
    #7
    Ok I fixed my problem, all I did is made sure my View Artwork was showing, when I dont have that little box down left corner causes the crashes, when its displaying everything runs fine. Test it out if it could be that.
     

Share This Page