iTunes Giving Funky iPod Error Messages

Discussion in 'iPod' started by JohnEZ, Sep 6, 2007.

  1. macrumors member

    My iPod started acting up recently, and would refuse to mount on the desktop the first time I plugged it in.... so I'd have to go back, unplug it, and plug it back in again. Frustrating, right?

    So I restored it from iTunes. Or at least that's what I thought I was doing. So I hit restore, I allowed it to sync back... and about 3/4 of the way through, it gives me this nice, neat, little error message:

    "Attempting to copy to the disk 'John's iPod' failed. An unknown error occurred. (-54)"

    I've tried to restore it again. I've tried to repair it in disk utility. Nothing quite seems to work.

    Is my iPod a goner? It's only 1.5 years old... that's not supposed to happen.

  2. macrumors 6502a


    A friend of mine had this problem, we tried everything (including Sprinrite) and we weren't able to get it working. Supposed logic board problem. Best bet is to contact apple (if you got applecare) otherwise you have an excuse to buy an iPod Touch.
  3. macrumors member

    Gah, that's frustrating. Nope, no Applecare on this thing... so I guess I won't be buying another iPod without that, that's for sure.

    iPod Touch, here I come...
  4. macrumors 6502a


    I thought it to be useless before, but after what happened to my buddy's, I purchased the applecare with my 8gb 2gen nano. My money is on that I won't need it though.

Share This Page