iTunes help: Some albums split regardless of info!

Discussion in 'Mac Applications and Mac App Store' started by adammcd, Dec 9, 2008.

  1. macrumors member

    Joined:
    Nov 15, 2007
    #1
    I have a somewhat common problem, but the usual solution doesn't seem to work for me. Here goes...

    The problem. For some of my albums in iTunes, the album gets spit into 2 (or more) separate albums. I have searched many forums threads & such for solutions, but all I can seem to find is advice telling the user to make sure all the appropriate info is the same for each track in the album. Although this is usually the problem, it seems something more is causing some of my albums to be separate.

    Here is an example. I have the album "Takk" by "Sigur Ros". The track names and track numbers are different (of course) but the following are all either the same for all tracks or are blank for all tracks:

    'Artist', 'Album Artist', 'Album', 'Grouping', 'Composer', 'Comments', 'Genre', 'Year', the 2nd part of 'Track Number', both parts of the 'Disc Number', 'BPM', 'Artwork', and 'Rating'.

    Also, the problem is not that there might be an extra space or something other that is slightly different -- this is because I actually selected all of the tracks and edited all this information at once. This is shown in the screen-shot below.
    [​IMG]

    I've checked every other setting I can think of and can't figure out why iTunes thinks 'track 1' should consist of its own album that is separate from the rest. This includes comparing the options under the 'Video', 'Sorting', & 'Options' tabs when looking at "Multiple Item Information". I also made sure that track 1 doesn't have "part of a compilation" checked or anything funny like that.

    This happens with many of my albums and I just can't figure out why. Any help would be appreciated.
     
  2. macrumors 603

    Joined:
    Feb 4, 2008
    #2
    That happens to me with "Christmas with the Rat Pack." It's quite annoying because you figure it would be sorted by the Album name, which is EXACTLY THE SAME. Thank goodness for playlists.
     
  3. macrumors 65816

    Tom B.

    Joined:
    Mar 22, 2006
    Location:
    London
    #3
    Select the entire album and change the album artist to 'Sigur Ros2', or just anything different than what it is at the moment. Then change it back to what it should be. Success!

    EDIT: I see you do not have the album artist field filled in. Any reason why not?
     
  4. macrumors regular

    Joined:
    Jan 24, 2008
    Location:
    Southampton, UK
    #4
    I was having this problem yesterday.... select all of the tracks, Get Info, and then go to the Sorting tab. There, tick and fill in the Artist and Album name, and they should group.
     
  5. macrumors 603

    Joined:
    Feb 4, 2008
    #5
    That was remarkably simple. Thanks. :)
     
  6. macrumors 6502a

    Joined:
    Jun 12, 2008
    #6
    Does anyone have any other tricks for this?

    I have always had this stupid problem... but this time, i have AC/DC's cd black ice, and nothing i have done will group them together. NOTHING.
     
  7. macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #7
    I had the same problem. Strangely enough this worked for me:

    1. Select all the songs of the album, press CMD-I so get the info-window, set the album artist field.

    2. Then select the options-tab on the right (inside the info-window), select "part of compilation", hit ok.

    3. Press CMD-I so get the info-window again and deselect "part of a compilation", hit ok.

    Don't know why it makes a difference to select and then deselect compilation, but it grouped the stuff together for me. :)
     

Share This Page