iTunes Home Sharing - Can't Import Library

Discussion in 'Mac Apps and Mac App Store' started by mantan, Dec 26, 2009.

  1. macrumors 65816

    Joined:
    Nov 2, 2009
    Location:
    By Grabthar's Hammer
    #1
    OK, I'm sure it's something very obvious...but I am at my wit's end trying to figure it out.

    I added a laptop to our home network that'll primarily be used by my wife. Most of our iTunes content is on my system. I wanted to share the library across the network and give her the option of importing tracks off mine. This will let the whole family use either computer to sync their iPods.

    I set up the Home Sharing option using verion 9.0.2 on both machines. I didn't use a password. I can see the other computer's libraries under 'Shared' on each system and access their files to play. But when I select the library, I don't get the 'Import' option that is listed in the Help menu instructions. Without being able to import the tracks, we have to go back to the main machine to sync.

    What am I missing? Thanks in advance!
     
  2. macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Is the new computer authorized with the iTunes account? You can have up to 5 computers authorized at the same time.
     
  3. macrumors member

    iRach

    Joined:
    Dec 11, 2009
    #3
    Sorry to jump in, i have managed to authorize my new mac with my itunes account but when i connect my iphone to sync my music it tells me that my iphone is linked to another library. Can someone please tell me how to link my phone to that library, i've been trying on and off all day and it's driving me potty! I thought that once my mac was authorized it would find my old library automatically :(
     
  4. macrumors newbie

    Joined:
    Jan 2, 2010
    #4


    I have the same problem! all 3 computers in are home are activated and authorized, that is we can see and play the music from all three computers but we cannot import the information. I was under the impression that, like other mac applications, clicking and dragging was all that is necessary. Am i way off base or just missing the obvious?

    As for the syncing with the iphone you should go click on the name of your phone in the left side bar. it will bring you to the page with tabs. click the music tab. "sync music" this will erase what you have on it, replace it with your existing account, as well as "unlink" from the other library.
     
  5. macrumors newbie

    Joined:
    Jan 2, 2010
    #5
    Victory!

    literally just figured it out!

    For all computers go to "store" then "turn off home share"

    then go back and "turn on home share"

    a new page will come up which require you to enter an ID and password.

    This is key: use only ONE account's information for all computers!! that is, if every computer in your home has a different iTunes account (which they logically would) just choose ONE. It has no significance to the final outcome. Just pick one and enter it in all computers.

    At this point the icons beside the users name should change from a blue square with a music note to a yellow house with the music note.

    Open the desired folder of ANOTHER library and click and drag as many song you want into YOUR library.

    Hope this helps!!
     
  6. macrumors 6502

    Joined:
    Mar 23, 2008
    Location:
    AK, USA
    #6
    I got to try this, thanks!
     
  7. macrumors 6502

    Benito

    Joined:
    Jan 5, 2010
    Location:
    Toronto, Canada
    #7
    I just searched and found this thread. I was trying to do the same thing yesterday and was reading info on the Apple.com site and found the same thing, that all the computers need to have the same Apple ID for the iTunes Store in order to properly share music. I guess after you've shared, you can then revert back to each computer's Apple ID.
     
  8. macrumors 6502

    Benito

    Joined:
    Jan 5, 2010
    Location:
    Toronto, Canada
    #8
    So the same iTunes account needs to be active on both computers at the same time to do this right?

    So in iTunes, you slick on Store, but then I do not see "turn off home sharing". Under Store, there is a De authorize Computer, is that you meant? When I click on deactivate computer it says that doing so will make any content purchased on this computer no longer play.
     
  9. macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #9
    That's not it. One menu to the right ("extended" im my language), you'll find "Activate Private Sharing" (or something similar in English). :)
     
  10. macrumors 6502

    Benito

    Joined:
    Jan 5, 2010
    Location:
    Toronto, Canada
    #10
    Ah OK, got it, click on Advanced, then turn off home sharing! Thanks so much.
     
  11. macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
  12. macrumors newbie

    Joined:
    Feb 23, 2010
    #12
    I have followed all the steps that you guys laid out, and this image does not pop up. I know it should be easy, and have heard so from many other people. But when we follow these instructions, nothing happens. Any other ideas or tips would be great! Thanks!
     
  13. macrumors 6502a

    Cinematographer

    Joined:
    Sep 12, 2005
    Location:
    far away
    #13
    Did you try: Store > Turn on home sharing

    Or did you try: Advanced > Turn on home sharing?
     
  14. macrumors newbie

    Joined:
    Feb 23, 2010
    #14
    Both. We did advanced first and then when that didn't work, we tried doing it from the store as well. So at one point both were logged in to the same acct.
     
  15. macrumors 6502

    Joined:
    Sep 30, 2007
    Location:
    NJ
    #15
    Do both machines have files in the same directories? I had a similar issue a few months back and I had to move my iTunes directory back to its default location on the machine I was copying from.
     
  16. macrumors newbie

    Joined:
    Feb 23, 2010
    #16
    No, well they shouldn't. The other computer is pretty much brand new, and only has a few albums and songs added to the library. We did try it a couple months back on an old computer and still had the same issues. I really have no idea what the deal is...
     
  17. macrumors newbie

    Joined:
    May 11, 2010
    #17
    import issues

    I know this may sound silly but it actually works
    Turn off sharing on all devices.
    Turn on sharing on each device one at a time.
    Here is the important part:::::
    Do not click on done until all computers show a yellow house in the shared column on the left side. Once all computers show the yellow house click done.

    I was fighting this same monster and this is what worked. Hope it helps.
     
  18. macrumors newbie

    Joined:
    May 15, 2010
    #18
    When doing all this turning on and off of sharing, on each computer, do I need to be connected to the internet for each one? I have a data card for internet usage so I can only access the internet one at a time...

    Also, I have been waiting for ten minutes for itunes to show my other computer under the little house in the shared column, and nothing is happening...

    I bought this computer to make life easier... So far it's not happenin'.

    I can't take it anymore - any help would be awesome!!!!!!!!!
     
  19. macrumors newbie

    Joined:
    May 19, 2010
    #19
    I found this thread after having the same problem for a couple months with not resolution but I finally got my home share to work after trying the recommendation to turn off all home shares, turn on ALL home shares, AND do not click "Done" on the home share page. After doing this my home shares finally worked, I have the yellow home icon next to my shared library instead of the blue pages and now I have the Import button back!!!

    Thanks for everyone's input, I hope this help you fix yours!
     
  20. macrumors newbie

    Joined:
    Jun 21, 2010
    #20
    transferring music between PCs using homje sharing

    We're trying to transfer my son's iTunes music from his old PC to his new one. Apparently he tried this (using home sharing) and many of the songs did not transfer. He uses the same iTunes account on both machines. However, when he first started using iTunes he was using my account, now he uses his own. My guess, is that those songs that were acquired using my account did not transfer because his new PC is not authorized to use that account. Does that make sense? My account is currently is use (active) and authorized on 5 of our PCs already. How do we transfer his songs that were purchased using my account? Thanks.
     
  21. macrumors newbie

    Joined:
    Dec 14, 2010
    Location:
    Male', Maldives
    #21
    Hey this actually worked for me!!! The thing here was that I had a prob with iTunes not importing more than 10 songs at a time... This trick fixed that wierd problem!
     
  22. macrumors newbie

    Joined:
    Mar 7, 2011
    #22
    i registered here just to say a big thank you!

    I registered here just to say Thank You!,I've been trying to find a solution for days! This worked!
     
  23. macrumors newbie

    Joined:
    Apr 21, 2011
    #23
    I also just registered to say thank you and just noticed that the last post was the same as what I was going to type!:p

    I thought that they took it away in 10 but it now works again.
     
  24. macrumors newbie

    Joined:
    May 13, 2014
    #24
    Don't let this happen to you.

    I already had the yellow house with the musical note but followed the suggested steps anyway. Here's where I got tripped up. The official document on the Apple site says to choose Edit > Select All to select all songs. Since this is what I wanted, this is what I did. Seemingly nothing happened and at this point, since all songs had a check mark next to them, I assumed they were all already selected, that's why it looked like Edit > Select All didn't do anything. No import option still.
    Then I had this brainstorm, select all songs by clicking the first then shift-click the last one, now all songs are highlighted and, lo and behold, import is now enabled and my import was successful.
     

Share This Page