iTunes importing error

Discussion in 'Mac Apps and Mac App Store' started by Shmegma, Dec 23, 2003.

  1. Shmegma macrumors newbie

    Joined:
    Dec 23, 2003
    #1
    I'm having a problem importing songs off of cd's in iTunes. The main problem is, I didn't have this issue before setting up a second user on the computer(my wife). I was able to import songs before I did that. Now when I try to import I get this error.....
    [​IMG]

    Since this happened, my cousin (whom I purchased the G4 from) suggested deleting my wifes user profile and going back to one user. He's never used multiple users on his Mac's and thought that's where the issue lied. Well, today I did just that but I'm still getting the error. I'm fairly new to Mac's and OSX and need some help. Could someone tell my why it's doing this now and where I might be able to fix it? Thankyou.
     
  2. crazytom macrumors 6502a

    crazytom

    Joined:
    Jul 23, 2002
    Location:
    IL
    #2
    The first thing you should do is open up Disk Utility and run Repair Permissions to see if that clears up the problem. Try it out and post back if that fixes it.
     
  3. Shmegma thread starter macrumors newbie

    Joined:
    Dec 23, 2003
    #3
    Nope, that didn't work. I don't know what happened but it was fine before I added the second user. Hope i didn't bung anything up! lol Any other suggestions?
     
  4. crazytom macrumors 6502a

    crazytom

    Joined:
    Jul 23, 2002
    Location:
    IL
    #4
    Recheck your iTunes preferences and make sure it's using the correct folder. Since you added another user, it may have locked down the system iTunes in place of independent user iTunes folders.

    Here's a quick and dirty solution; this assumes that you trust everyone on your computer/network.

    Find the iTunes music folder, it will either be in Library/iTunes or ~/Library/iTunes (the ~ being your home directory). Click on the folder once and type <apple>-I. This will pull up the info window. Click on the Details triangle. In the details section is will show the Owner and Access. This ~should~ be your username or 'Admin'. To make things easy, change the access of everything (owner, group, and others) to be read and write. This may require an admin password and click 'Apply to enclosed items'. This should clear things up.

    Unfortunately, I can't give you what it should be exactly because I've messed with my system quite a bit in the last month, and moved my iTunes folder to an entirely different hard drive than my system drive... Maybe someone with a clean install can provide the proper owner, group and other settings....
     
  5. Shmegma thread starter macrumors newbie

    Joined:
    Dec 23, 2003
    #5
    Ok, I clicked on the folder and made the 'access' section read/write from read only. Then I went into the iTunes preferences and changed the importing save folder back to the default. We had changed the save location for imported folders so that both my wife and I could access the same imported music files without imorting them twice to our own folders. It has cleared that up now and i'm importing as I type this. Thanks so much for all your help. I'm very glad to have found this board and will keep visiting to feed my brain with tips and tricks for using my new Mac. Thanks again.
     

Share This Page