ITUNES IN HEBREW, virus? Please Help

Discussion in 'Mac Apps and Mac App Store' started by galavisjoe, Apr 27, 2005.

  1. galavisjoe macrumors newbie

    Joined:
    Apr 27, 2005
    #1
    ITunes suddenly decided to start displaying everything in Hebrew
    Menu bar, preferences and the music store still in engligh. Everything else is in Hebrew.
    I tried trashing iTunes and reinstalling, deleting preference files like 5 times. Nothing works.
    If someone knows how to fix this problem please explain me step by step. I am a rookie in Mac's.
    Thanks,
     
  2. mac-er macrumors 65816

    Joined:
    Apr 9, 2003
  3. rickvanr macrumors 68040

    rickvanr

    Joined:
    Apr 10, 2002
    Location:
    Brockville
    #3
    Is this only happening in iTunes?

    I'd check out International Pane in the System Preferences.

    Edit, Quirky Note: Once on my Mom's computer the System Profiler was in some Asian font, a full re-install of the OS solved it.
     
  4. galavisjoe thread starter macrumors newbie

    Joined:
    Apr 27, 2005
    #4
  5. galavisjoe thread starter macrumors newbie

    Joined:
    Apr 27, 2005
    #5
    Yes only in Itunes, I allready check the international pane and my system is in engligh.
     
  6. mac-er macrumors 65816

    Joined:
    Apr 9, 2003
    #6
    Well, did you read the link I provided you?
    :confused:

    (People on here like to know if your problem was resolved).

    One of the fonts you installed probably has the same name as a system font.

    Delete or change the name of the font you installed that has the same name of the system font.
     
  7. galavisjoe thread starter macrumors newbie

    Joined:
    Apr 27, 2005
    #7
    I dont now? I do not find the font that is overlaping the system one.
    I am lost.
     
  8. CazMac macrumors newbie

    Joined:
    May 17, 2005
    #8
    Go to Fontbook, find Lucida Grande and delete the most recent version. iTunes should go back to normal :)
     
  9. MontyZ macrumors 6502a

    Joined:
    Jan 7, 2005

Share This Page