iTunes & iPod in 10.3 7B21

Discussion in 'Macintosh Computers' started by Jimmni, Jul 29, 2003.

  1. macrumors member

    Joined:
    May 1, 2003
    #1
    Hi all,

    First off, sorry if this is in the wrong place, or has already been discussed. I think I checked these both pretty thoroughly.

    Second, the main point. I'm running 10.3 7B21. I'll not coment on anything covered by the NDA. I do, though, want to discuss a certain bug in 10.3. This is a word of warning to iPod owners, and a plea for help.

    After installing 7B21 I've had a major problem. Ever time I load iTunes to update my iPod, without fail, it will crash. This means it's been impossible for me to update my iPod since installing 7B21. This is a big issue for me. I use my iPod all the time, and can't be doing with it not getting updated when I buy new albums. I don't do that all that often, but one arrived in the post from Amazon this morning, and I really want to get it on my iPod. It might be a bug peculiar to my system, or it might be a bug in 7B21. Please reply if you have tried your iPod on 7B21, and let me know what results you got.

    On a side note; I tried every iPod utility I could find. Loads of them let me take music off my iPod, but none seem to let me put any ON it. Anyone know of a utility that does this? Or how I can safely put songs directly into the iPod's seemingly random music directory? I even tried other MP3 players like Audion. They support iPods, but I can't get them to do what I need. Preferably I want to organise my music and have it auto update, like with iTunes. I'll settle for being able to just plonk new albums on it.

    Any thought, help, experiences?

    Thanks... Jimmni
     
  2. macrumors 604

    iJon

    Joined:
    Feb 7, 2002
    #2
    your a developer, shouldnt you be figuring this out or contacting apple.

    iJon
     
  3. thread starter macrumors member

    Joined:
    May 1, 2003
    #3
    Encouraging response, thanks. Anyway, I may be a developer but that doesn't mean I'm a technical genius. I have no idea how the iPod and iTunes do their communicating. I've submitted a bug report to Apple, but since when did they immediately respond to every bug report and rush out fixes?

    - Jimmni
     
  4. macrumors 6502a

    Joined:
    Jun 9, 2002
    Location:
    Europe
    #4
    Jeez iJon, there's no need for that.

    Jimmni, Have you tried erasing the iPod and reinstating it with the ipod updater?

    If that doesn't work why don't you try erasing the hard disk in the finder. I'm not an iPod owner tho so these are jsut suggestions. I hope it helps.
     
  5. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #5
    You really should have beta OSes installed on a separate partition or disk, especially when testing on your main/only machine.

    I can't confirm the issue with that build, since I haven't received it yet...should come in today.
     
  6. thread starter macrumors member

    Joined:
    May 1, 2003
    #6
    I have 10.2 at work, where smooth functionality really matters, and installed 10.3 on my home, personal machine to test in my own time. There's nothing I'd be too sorry to lose on here, and I do frequent backups. There's not enough disk space to have 3 OSes on here, and I think it's worth the very, very minor instability and the bugs to be trying Panther extensively. Until now, that is.

    - Jimmni
     
  7. Moderator emeritus

    Rower_CPU

    Joined:
    Oct 5, 2001
    Location:
    San Diego, CA
    #7
    Yeah, it's fine when it goes smoothly but when it doesn't...;)

    Even a little Firewire drive would do nicely for OS testing.
     
  8. macrumors 604

    iJon

    Joined:
    Feb 7, 2002
    #8
    sorry, my intent wasnt to be rude. its just you have a beta os, probably apple fixed one bug and it made another. wish i could tell you something but i dont have that version. try reinstalling itunes or confirm with someone else with that version of panther.

    iJon
     
  9. macrumors newbie

    Joined:
    Jul 30, 2003
    #9
    I actually have the same problem with my iPod and 10.3 v7B21

    if anyone solves this problem please let me know!

    thanks
     

Share This Page