ITUNES IS NOT OPENING

Discussion in 'Mac Apps and Mac App Store' started by Billy33, Jun 8, 2005.

  1. Billy33 macrumors newbie

    Joined:
    Aug 15, 2004
    #1
    My Itunes 4.8 is not opening, I keep on clicking on the icon, restarting the computer, and it does not open, it opens about once every two days after trying several times.

    I use a Powerbook G4 with Mac OS X 10.3.9, I also use a 40gig Ipod with my computer,
    and about 4 weeks ago Itunes started giving me trouble, but right now is very frustrating because it seems like it is running (it has the black arrow next to the Icon) but no Itunes window opens. I’ve tried pluggin/unplugging my Ipod, Running disc uitility to clean the hard drive since it is pretty full because I constantly work with heavy audio files.
    Another thing is all my music is stored on an external hard drive, but it is all played through Itunes.
    I do not know if I should reinstall Itunes, and in such case, I do not have the cd currently with me, where can I download the software?

    Thanks for all the help you can provide me.
    Billy
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    You can download iTunes here but before you do that, I recommend ditching the iTunes preferences.
     
  3. Apple macrumors 6502

    Apple

    Joined:
    Mar 3, 2005
    Location:
    Charlotte, NC
    #3
    Just to add to what mad jew said, run a search for everything dealing with itunes and delete them (minus the songs) then you'll be fine.
     
  4. TrenchMouth macrumors 6502

    Joined:
    Nov 21, 2002
    #4
    I had a similar issue and narrowed it down to a preferences issue. It started after i had difficulty connecting to other peoples libraries over a network. They had an older version and mine would lock up for some reason. I would quit iTunes and when i started it back up i would just get the black arrow. Worst part was, if i tried to restart my computer it would just relaunch the Finder, and it wouldnt let me do anything but a hard shutdown. totally sucked

    Again, trashing the preferences fixed it for me. That and telling everyone else to upgrade.
     

Share This Page